Iniziare con Rails 2.0

Ciao a tutti, sono nuovo del mondo Ruby on Rails, ho scaricato la
versione 2.0 di Rails dopo aver installato Ruby 1.8.6 ed utilizzando "e

  • text editor" ho seguito il tutorial di agile web development per la
    creazione di “hello world.rhtml”. Ora mi da questo errore quando carico
    la pagina:

LoadError in SayController#Hello
127: Impossibile trovare la procedura specificata. - Init_sqlite3
C:/RP/Web/lib/sqlite3.dll
RAILS_ROOT: C:/RP/Web

Cercando in rete ho scoperto che hanno cambiato il db di default in
Rails, passando a SQLite3. Io però non riesco ad installarlo.
Ho provato:

  • gem install sqlite3
  • gem install sqlite3-ruby
  • ho scaricato tutti gli exe e dll dal sito SQLite.org ed ho provato a
    copiarli in ogni possibile cartella dell’applicazione e
    dell’installazione di Ruby, ma non c’è stato niente da fare! Qualcuno
    può aiutarmi?
    Grazie, Alessandro

Alessandro Vanni wrote:

Ciao a tutti, sono nuovo del mondo Ruby on Rails, ho scaricato la
versione 2.0 di Rails dopo aver installato Ruby 1.8.6 ed utilizzando "e

  • text editor" ho seguito il tutorial di agile web development per la
    creazione di “hello world.rhtml”. Ora mi da questo errore quando carico
    la pagina:

LoadError in SayController#Hello
127: Impossibile trovare la procedura specificata. - Init_sqlite3
C:/RP/Web/lib/sqlite3.dll
RAILS_ROOT: C:/RP/Web

Cercando in rete ho scoperto che hanno cambiato il db di default in
Rails, passando a SQLite3. Io però non riesco ad installarlo.
Ho provato:

  • gem install sqlite3
  • gem install sqlite3-ruby
  • ho scaricato tutti gli exe e dll dal sito SQLite.org ed ho provato a
    copiarli in ogni possibile cartella dell’applicazione e
    dell’installazione di Ruby, ma non c’è stato niente da fare! Qualcuno
    può aiutarmi?
    Grazie, Alessandro

Per usare SQLite su Rails 2.0 devi completare 2 passi:

  1. installare il motore SQLite (e questo è indipendente da ruby)
  2. installare la gem sqlite3-ruby valida per Ruby

Puoi procedere nell’ordine che preferisci.
La gem è installata?

Per installare SQLite su Windows scarica
http://www.sqlite.org/sqlite-3_5_4.zip
http://www.sqlite.org/sqlitedll-3_5_4.zip
e copiali in windows/system32
Poi riavvia il sistema.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs