Increasing open files limit

I am trying to increase the limit on open files for nginx. I’ve set cat
/proc/sys/fs/file-max to 1000000, set worker_rlimit_nofile to 8388608
but I
still keep getting errors like:

setrlimit(RLIMIT_NOFILE, 8388608) failed (1: Operation not permitted)
accept4() failed (24: Too many open files)

How do I increase the limit on open files for nginx?

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,248426,248426#msg-248426

On Mon, 2014-03-17 at 00:53 -0400, bignginxfan wrote:

In /etc/sysctl.conf or a conf file in /etc/sysconfig.d

fs.file-max = 1000000

and run /etc/sysctl -p /etc/sysctl.conf

in /etc/security/limits.conf

www-data soft nofile 500000
www-data hard nofile 800000

( assuming nginx is running as www-data ).

However, check your figures… setting max to a million open files, then
trying to set rlimit_nofile to 8 million is never going to work! I
suggest 800k should be plenty.

Steve


Steve H. BSc(Hons) MIITP
http://www.greengecko.co.nz
Linkedin: http://www.linkedin.com/in/steveholdoway
Skype: sholdowa

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs