Incorrect log being generated?

Using the following,

log_format main '$remote_addr - $remote_user [$time_local]  '
                '"$request" $status $body_bytes_sent '
                '"$http_referer" "$http_user_agent"';

access_log  logs/access.log  main;

Notice the extra “-”'s…

::ffff:173.175.52.41 - - [29/Dec/2011:07:29:57 -0600] “GET /text.txt
HTTP/1.1” 200 14457 “-” “Mozilla/5.0 (Windows NT 5.1; rv:8.0)
Gecko/20100101 Firefox/8.0”
::ffff:83.108.225.71 - - [29/Dec/2011:07:29:57 -0600] “GET /text.txt
HTTP/1.1” 200 130968 “-” “Mozilla/5.0 (X11; U; Linux i686; nb-NO;
rv:1.9.2.18) Gecko/20110628 Ubuntu/10.10 (maverick) Firefox/3.6.18”
::ffff:31.47.127.66 - - [29/Dec/2011:07:29:57 -0600] “-” 400 0 “-” “-”
::ffff:81.184.25.193 - - [29/Dec/2011:07:29:57 -0600] “GET /text.txtt
HTTP/1.1” 200 130968 “-” “Mozilla/5.0 (Windows NT 6.1; rv:8.0)
Gecko/20100101 Firefox/8.0”
::ffff:211.128.160.26 - - [29/Dec/2011:07:29:57 -0600] “GET /text.txt
HTTP/1.1” 200 5068 “-” “Mozilla/5.0 (Windows NT 5.1; rv:2.0)
Gecko/20100101 Firefox/4.0”
::ffff:61.5.222.223 - - [29/Dec/2011:07:29:57 -0600] “GET /text.txt
HTTP/1.1” 200 130968 “-” “Mozilla/5.0 (Windows NT 6.1; WOW64;
rv:8.0.1) Gecko/20100101 Firefox/8.0.1”
::ffff:81.182.240.97 - - [29/Dec/2011:07:29:57 -0600] “GET /text.txt
HTTP/1.1” 200 130968 “-” “Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0)
Gecko/20100101 Firefox/8.0”

(nginx compiled)
nginx version: nginx/1.1.11
built by gcc 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
TLS SNI support enabled
configure arguments:
–with-openssl=/root/openssl-1.0.1-stable-SNAP-20111218
–with-http_gzip_static_module --with-http_ssl_module --with-ipv6
–without-mail_pop3_module --without-mail_imap_module
–without-mail_smtp_module --without-http_charset_module
–without-http_ssi_module --without-http_userid_module
–without-http_autoindex_module --without-http_rewrite_module
–without-http_limit_zone_module --without-http_limit_req_module

nginx config: http://pastebin.com/raw.php?i=k3PWs45H

Restarting nginx hasn’t helped either. Have I disabled a module or
haven’t enabled a module I needed?

I’m just having issues getting awstats to parse the log file being
generated by nginx

The logs are showing extra “-”'s, where there should be none? The extra
“-”
breaks awstats parsing

Hello!

On Fri, Dec 30, 2011 at 03:08:11AM +1300, Ryan B. wrote:

I’m just having issues getting awstats to parse the log file being
generated by nginx

I suspect awstats have issues with ipv6 addresses. You may try
feeding it with the same log lines but with plain ipv4 addresses
instead to see if it helps.

Maxim D.

                '"$http_referer" "$http_user_agent"';

HTTP/1.1" 200 130968 “-” “Mozilla/5.0 (X11; U; Linux i686; nb-NO;
rv:8.0.1) Gecko/20100101 Firefox/8.0.1”
–with-openssl=/root/openssl-1.0.1-stable-SNAP-20111218
haven’t enabled a module I needed?

Hello!

On Fri, Dec 30, 2011 at 03:24:08AM +1300, Ryan B. wrote:

The logs are showing extra “-”'s, where there should be none? The extra “-”
breaks awstats parsing

Again: where you see extra “-”'s?

Maxim D.

Using the following,
::ffff:173.175.52.41 - - [29/Dec/2011:07:29:57 -0600] “GET /text.txt
HTTP/1.1” 200 5068 “-” "Mozilla/5.0 (Windows NT 5.1; rv:2.0)
nginx version: nginx/1.1.11


nginx mailing list
[email protected]
http://mailman.nginx.org/mailman/listinfo/nginx

Hello!

On Fri, Dec 30, 2011 at 02:35:39AM +1300, Ryan B. wrote:

::ffff:211.128.160.26 - - [29/Dec/2011:07:29:57 -0600] "GET /text.txt
(nginx compiled)
–without-http_limit_zone_module --without-http_limit_req_module

nginx config: http://pastebin.com/raw.php?i=k3PWs45H

Restarting nginx hasn’t helped either. Have I disabled a module or
haven’t enabled a module I needed?

It’s not clear what you are consider to be wrong. Everything
looks fine and perfectly correct from here.

Maxim D.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs