Inching towards a working 1.1.6 app

I have an old app that I’m trying to get running on Dreamhost. I
finally sorted out that it was built on rails 1.1.6 (did I mention
that it is old? it is old.) and went about specifying 1.1.6 in
environment.rb:

RAILS_GEM_VERSION = ‘1.1.6’ unless defined? RAILS_GEM_VERSION

And I pieced together that I need to be using 1.1.x gems, so I checked
them out to vendor/rails:

svn co
http://svn.rubyonrails.org/rails/branches/1-1-stable/activesupport
svn co http://svn.rubyonrails.org/rails/branches/1-1-stable/activerecord
svn co http://svn.rubyonrails.org/rails/branches/1-1-stable/actionmailer
svn co http://svn.rubyonrails.org/rails/branches/1-1-stable/release.rb
svn co http://svn.rubyonrails.org/rails/branches/1-1-stable/railties
svn co http://svn.rubyonrails.org/rails/branches/1-1-stable/actionpack
svn co
http://svn.rubyonrails.org/rails/branches/1-1-stable/actionwebservice

Now when I try to run script/server I get an error more like this
(yeah, my app is in a directory called “frozeCSA” because I think what
I’m doing is freezing the rails version):

[0 [email protected] frozeCSA]$ ./script/server
=> Rails application started on http://0.0.0.0:3000
=> Ctrl-C to shutdown server; call with --help for options
[2008-05-15 07:39:58] INFO WEBrick 1.3.1
[2008-05-15 07:39:58] INFO ruby 1.8.5 (2006-08-25) [i386-linux]
[2008-05-15 07:39:58] INFO WEBrick::HTTPServer#start: pid=2456
port=3000
Killed

That is better than it was, by a long shot, but it does launch on an
odd IP address and then it gets killed before it is up.

Where should I take this from here?

PS, yes, these are the same puzzle:
http://groups.google.com/group/rubyonrails-talk/browse_thread/thread/3e8564f6b0885a74/150378cdbba7048b
http://groups.google.com/group/rubyonrails-talk/browse_thread/thread/d6cd34bbc9d52bc7/03180960f81c452b

RAILS_GEM_VERSION = ‘1.1.6’ unless defined? RAILS_GEM_VERSION

And I pieced together that I need to be using 1.1.x gems, so I checked
them out to vendor/rails:

svn co http://svn.rubyonrails.org/rails/branches/1-1-stable/activesupport

If you just do ‘sudo gem install rails -v=1.1.6’, it will take care of
all this
bookyuck automatically, right?

“sudo” being the heel of that achilles. Am I just doomed on
Dreamhost?

Argh.

You can freeze particular versions of Rails:

rake rails:freeze:edge TAG=rel_1-1-6

On Mon, May 19, 2008 at 9:56 PM, Amanda [email protected] wrote:


Appreciated my help?
Reccommend me on Working With Rails
http://workingwithrails.com/person/11030-ryan-bigg

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs