In dev, how can I make assets/javascripts changes show up in browser (rails 3.2/chrome 21)

Sometimes – like now – my favorite dev browser, Chrome (v.21), will
not
show changes made in my Rails 3.2 assets/javascripts files. Is this a
Chrome thing, or how can I get the changes to show up immediately upon
page
refresh?

Thanks,

G

Is this while you are developing on localhost? Do you have the assets
pipeline configured correctly in your development.rb environment file?
It should be set to auto-recompile on each request. If Chrome is showing
you this issue, try using Safari or Firefox and see if the problem
travels – it could be Rails, but it could just be your browser. See if
there’s a hidden Chrome option to disable cacheing for certain domains
or globally. I have Firefox set to use zero disk and memory cache. Yes,
it’s slower for everything, but I don’t have to hold down the Shift key
and press Reload to force-refresh while making tiny changes to scripts
either, and I don’t use Firefox for daily Web driving anyway.

Walter

On Oct 14, 2013, at 9:28 AM, G-money [email protected] wrote:

Sometimes – like now – my favorite dev browser, Chrome (v.21), will not show
changes made in my Rails 3.2 assets/javascripts files. Is this a Chrome thing, or
how can I get the changes to show up immediately upon page refresh?

In Chrome, I turn off caching in the DevTools (it means you need to keep
them running, I think.) There’s probably an easier way to get to them,
but once I have the DevTools up, I click on the little sprocket in the
lower right corner and I can then configure the browser.

I don’t know if this will fix your issue, but at least you can be sure
it isn’t browser caching that’s the problem. Hope this helps.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs