Impossible installer sqlite3-ruby


#1

Bonjour,

Après avoir installé Ruby 1.8.6 et rubygems 0.9.x sous Windows XP (ruby
one-click ruby186-26), puis rails, et mis à jour rubygems (gem update
–system) suite à une protestation du script generate qui m’a demandé de
faire cette manip, je ne parviens plus à installer sqlite3 (gem install
sqlite3-ruby).

En fait, rubygems (v1.3.1) essaie d’exécuter la commande 'nmake’qui ne
figure évidemment pas sur mon disque, et avorte l’installation avec le
message suivant :

‘nmake’ n’est pas reconnu en tant que commande interne ou externe
…etc.

Pourtant, il me semblait que cette installation fonctionnait
parfaitement avant la mise à jour de rubygems.

Quelqu’un peut-il m’aider?


#2

Le 23 janvier 2009 15:34, Didier a écrit :

Après avoir installé Ruby 1.8.6 et rubygems 0.9.x sous Windows XP (ruby
one-click ruby186-26), puis rails, et mis à jour rubygems (gem update
–system) suite à une protestation du script generate qui m’a demandé de
faire cette manip, je ne parviens plus à installer sqlite3 (gem install
sqlite3-ruby).

En fait, rubygems (v1.3.1) essaie d’exécuter la commande 'nmake’qui ne
figure évidemment pas sur mon disque,

oui mais il est installable, il te faut un compilateur C.

et avorte l’installation avec le
message suivant :

‘nmake’ n’est pas reconnu en tant que commande interne ou externe
…etc.

Sur http://rubyforge.org/frs/?group_id=254&release_id=25302
sqlite3-ruby-1.2.4 n’est pas disponible pour Windows sous
forme précompilée, du coup RubyGems cherche à compiler
1.2.4 et comme t’as pas de compilateur, ça plante.

Donc de deux choses l’une :

  • soit t’installes un compilo C
  • soit t’installes sqlite3-ruby-1.2.3 qui existe sous
    forme *-mswin32.gem

Pourtant, il me semblait que cette installation fonctionnait
parfaitement avant la mise à jour de rubygems.

Quelqu’un peut-il m’aider?

ça dépend, tu donnes combien de points de récompense ?

– Jean-François.


http://twitter.com/underflow_