Impossible d'utiliser Rmagick (RubyEE 1.8.6 / ImageMagick 6.4.1 source)


#1

Bonjour à tous

Cela fait maintenant deux jours que je peine à faire fonctionner
Rmagick sur mon serveur de production. Malgré tous mes test, j’obtiens
toujours ce message d’erreur lorsque je tente d’envoyer une image via
mon application :

libMagickCore.so.1: cannot open shared object file: No such file or
directory - /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/
rmagick-2.9.1/lib/RMagick2.so

/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/
rmagick-2.9.1/lib/RMagick2.so
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:36:in require' /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/ activesupport-2.2.2/lib/active_support/dependencies.rb:153:inrequire’
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
new_constants_in' /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/ activesupport-2.2.2/lib/active_support/dependencies.rb:153:inrequire’
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/
rmagick-2.9.1/lib/RMagick.rb:11
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:31:in gem_original_require' /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:31:inrequire’
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:153:in require' /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/ activesupport-2.2.2/lib/active_support/dependencies.rb:521:innew_constants_in’
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:153:in require' /home/web/myapp/ftp/www/app/models/logo.rb:18:invalidate’
/home/web/myapp/ftp/www/app/controllers/creations_controller.rb:81:in
`send_logos’

This error occurred while loading the following files:
RMagick
RMagick2.so

Si cela peut-être utile, j’ai du compiler ImageMagick depuis les
sources, j’ai lu pas mal de sujets similaires parlant de variables
d’environnements problématique lorsque l’on compilait ImageMagick,
mais aucune des solutions que j’ai trouvé n’a
fonctionné.
Ma configuration :

Ruby Enterprise 1.8.6
Rails 2.2.2
ImageMagick 6.4.1
rmagick 2.9.1

Quelqu’un aurait-il déjà eu un problème similaire?

Merci!

Bousmanne Cédric
http://cedricbousmanne.com/