Imcompatibility between GRC version and the USRP FW

HI

I am presently trying to work with USRP N210 with a SBX daughter board
connected to a Host laptop with Ubuntu 12.10 installed.This laptop had a
version of GRC and UHD installed when I got it.
But even though I was able to run some uhd example programs like
tx_waveform
and uhd_siggen_gui.py iw as unable to run uhd_fft.py directly from the
uhd
utilities. The error showed that some libraries are missing and hence I
decided to update the uhd,grc version.
However, the USRP with the daughter board was not getting recognised
with
uhd_usrp_probe command. So after the googling I found some people
suggesting
that fw on the usrp needed to be updated too.
Though I have burned the latest images of usrp_n210_fw.bin and
usrp_n210_fpga_r4.bin into usrp ,still it is not working. I get the
foll
error message:

Error:Runtime Error
Please update the firmware and fpga images for your device
Expected protocol compatibility number [7 t 11], got 12
The firmware is not compatible with the host code build.

I am stuck and google is not providing any different answers. how do I
know
which is the compatible version for the current uhd and GRC
Any help will be greatly appreciated.

Thanks
Gayathri


View this message in context:
http://gnuradio.4.n7.nabble.com/Imcompatibility-between-GRC-version-and-the-USRP-FW-tp47248.html
Sent from the GnuRadio mailing list archive at Nabble.com.

Hi Gayathri - I’ll email you off-list with what to try to get the N210
working again. - MLD

On 3/26/14 8:08 PM, Gayathri Ramasubramanian wrote:

Though I have burned the latest images of usrp_n210_fw.bin and
usrp_n210_fpga_r4.bin into usrp ,still it is not working. I get the foll
error message:

Error:Runtime Error
Please update the firmware and fpga images for your device
Expected protocol compatibility number [7 t 11], got 12
The firmware is not compatible with the host code build.

It looks like still have the wrong fpga & fw images. You need to
uninstall UHD and reinstall the latest version from ettus.
This will get you the latest fw & fpga. THEN burn them
into the USRP N210. You should probably rerun make and
make install on gnuradio as well to insure you are linked
to the new UHD libraries.

@(^.^)@ Ed

On 03/27/2014 02:01 AM, Ed Criscuolo wrote:

The firmware is not compatible with the host code build.

It looks like still have the wrong fpga & fw images. You need to
uninstall UHD and reinstall the latest version from ettus.
This will get you the latest fw & fpga. THEN burn them
into the USRP N210. You should probably rerun make and
make install on gnuradio as well to insure you are linked
to the new UHD libraries.

Also, for the record, it seems like you’re using old versions of GNU
Radio, and maybe UHD, too. uhd_fft.py hasn’t been called that for a long
time now. I recommend you clear out your GR and UHD installs completely,
and start from scratch.

Cheers,
Martin

And to complete the whole story, this is a good starting point:
http://gnuradio.org/redmine/projects/gnuradio/wiki/InstallingGR

Or for installing from source:
http://gnuradio.org/redmine/projects/gnuradio/wiki/InstallingGRFromSource

I personally prefer the buildinstall-script, not the pybombs stuff what
takes too much control out of my hands.

Ralph.

Also, for the record, it seems like you’re using old versions of GNU
Radio, and

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs