Image voodoo failing in jruby 1.4.0RC1

Having a problem where image_voodoo no longer works under jruby
1.4.0RC1,
anyone have any idea?

/opt/jruby-1.4.0RC1/lib/ruby/gems/1.8/gems/image_voodoo-0.6/lib/image_voodoo/awt.rb:15:in
to_java': too big for signed byte: 253 (TypeError) from /opt/jruby-1.4.0RC1/lib/ruby/gems/1.8/gems/image_voodoo-0.6/lib/image_voodoo/awt.rb:15 from /opt/jruby-1.4.0RC1/lib/ruby/gems/1.8/gems/image_voodoo-0.6/lib/image_voodoo/awt.rb:31:inrequire’
from
/usr/local/jruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
require' from /Users/ycha/sandbox/cms_branches/experiment/vendor/rails/activesupport/lib/active_support/dependencies.rb:153:inrequire’
from
/Users/ycha/sandbox/cms_branches/experiment/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in
new_constants_in' from /Users/ycha/sandbox/cms_branches/experiment/vendor/rails/activesupport/lib/active_support/dependencies.rb:153:inrequire’
from
/opt/jruby-1.4.0RC1/lib/ruby/gems/1.8/gems/image_voodoo-0.6/lib/image_voodoo.rb:40
from
/opt/jruby-1.4.0RC1/lib/ruby/gems/1.8/gems/image_voodoo-0.6/lib/image_voodoo.rb:31:in
require' ... 70 levels... from /Users/ycha/sandbox/cms_branches/experiment/vendor/rails/railties/lib/commands/server.rb:31:inrequire’
from
/usr/local/jruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require’
from /Users/ycha/sandbox/cms_branches/experiment/script/server:3

~Matt

This is fixed in upcoming JRuby 1.4.0RC2. Thanks for mentioning it
though.

We had a logic bug in coercing numeric Java values in RC1 which has
since been fixed.

-Tom

On Fri, Oct 16, 2009 at 3:01 PM, Matthew K. removed_email_a[email protected]
wrote:

/usr/local/jruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
from
`require’
from /Users/ycha/sandbox/cms_branches/experiment/script/server:3

~Matt


blog: http://blog.enebo.com twitter: tom_enebo
mail: [email protected]


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs