IE issues (go figure)


#1

So, I have this issue with IE. The code below is from my view and
makes an ajax call to return a list of subcategories. The form works
just dandy in Chrome/Safari, and Firefox, but IE the Submit button
does absolutely nothing. Click it–nothing–no error, no nothing.

Anybody have an ideas?

My view

New Listing

<%= error_messages_for :listing %>

<% form_for(@listing) do |f| %>

<%= render :partial => “form”, :locals => {:f => f} %>

<%= f.submit "Create", :disable_with => "Saving..." %> <%= link_to 'Back', show_my_listings_url(current_user.id) %>

<% end %>

Form partial

<%= f.hidden_field :user_id, :value => current_user.id %>

Name
<%= f.text_field :name %>

Category:
<% form_tag "", :id=>"categories" do %> <% for category in @categories %> <% if @listing.category %> <% if @listing.category.parent == category %> <%= radio_button "category", :category_id, category.id, :checked => true %> <%= category.name %>
<% else %> <%= radio_button "category", :category_id, category.id %> <%= category.name %>
<% end %> <% else %> <%= radio_button "category", :category_id, category.id %> <%= category.name %>
<% end %> <% end %> <% end %>

Subcategory:

<%= render :partial => "categories/subcategories", :locals => {:subcategories => @subcategories} %>

<%= observe_form :categories,
:frequency => 0.5,
:url => { :controller => “categories”, :action =>
“ajax_subcategories” } %>

Gender:
<%= f.radio_button :gender, "Male" %> Male <%= f.radio_button :gender, "Female" %> Female

Location:
<%= f.text_field :location, :value => current_user.location %>

Price
<%= f.text_field :price %>

Description
<%= f.text_area :description %>