IE empty params

Hi,

Im getting a strange problem. I have a rails application (running rails
3.0.0), which uses NTLM to deal with the auth. The problem is that, with
IE (all versions) when we use POST as a result of a form, the “params”
variable is always empty, and so the application crashes. The strangest
thing is that it works with both Firefox and Chrome, and in IE when I
TURN OFF the NTLM. Also there is another application running on the same
server, that uses IE and NTLM, with basiclly the same configurations (i
guess) and runs OK. The only difference is that it runs on rails 2.2.2.

Has anyone got any ideia why this is happening ?

Thank a lot!

On 10 January 2011 15:07, Roger C. [email protected] wrote:

Has anyone got any ideia why this is happening ?

Have you checked that the html of the page is valid by copying the
complete page html (View > Page Source or similar in your browser) and
pasting it into the w3c html validator site? Differing operation
between browsers is often the result of invalid html.

Colin

Colin, tks for you answer.

Yes i isolated the form and ran the check and everything seemed ok. This
is really getting anoying, its been week like this…

Regards,
RPC.

On 10 January 2011 16:27, Roger C. [email protected] wrote:

Please don’t top post, it makes it difficult to follow the thread.
Insert your comments into the previous post at appropriate points.
Thanks

Colin, tks for you answer.

Yes i isolated the form and ran the check and everything seemed ok. This
is really getting anoying, its been week like this…

Did you copy/paste the complete source of the page?

Are you using javascript? If so try with firebug in firefox and see
if it gives any errors.

Could it be a Rails 3.0.0 issue? Perhaps an upgrade to 3.0.3 would be
advisable.

Colin

On 12 January 2011 15:20, Roger C. [email protected] wrote:

[…]
Yes i’ve also tried the complete source, i am not using javascript and i
upgraded today for Rails 3.0.3 and the problem persists… I just cant
understand why it works when i take the NTLM auth method out of the
picture…

If you look at the app log and compare it between FF and IE what
differences do you see?

You could post the relevant bits of log if appropriate.

Colin

Colin L. wrote in post #973693:

On 10 January 2011 16:27, Roger C. [email protected] wrote:

Please don’t top post, it makes it difficult to follow the thread.
Insert your comments into the previous post at appropriate points.
Thanks

Colin, tks for you answer.

Yes i isolated the form and ran the check and everything seemed ok. This
is really getting anoying, its been week like this…

Did you copy/paste the complete source of the page?

Are you using javascript? If so try with firebug in firefox and see
if it gives any errors.

Could it be a Rails 3.0.0 issue? Perhaps an upgrade to 3.0.3 would be
advisable.

Colin

Sorry for the bad posting.

Yes i’ve also tried the complete source, i am not using javascript and i
upgraded today for Rails 3.0.3 and the problem persists… I just cant
understand why it works when i take the NTLM auth method out of the
picture…

Thanks in advance

On 12 January 2011 17:21, Roger C. [email protected] wrote:

Internet Explorer:
telephone, updated_at) VALUES (NULL, ‘2011-01-12 17:15:22’, NULL,
“telephone”=>“34243”, “age”=>“3242”},
** Params: {“commit”=>“Create Person”, “person”=>{“name”=>“dasd”,
“telephone”=>“34243”, “age”=>“3242”},
“authenticity_token”=>“6U9cHxuI6gW3WPbZoe+i93Tbu+oWjohdv+nuwb/8QXY=”,
“utf8”=>"", “action”=>“create”, “controller”=>“people”}
SQL (0.1ms) BEGIN
SQL (0.2ms) INSERT INTO people (age, created_at, name,
telephone, updated_at) VALUES (3242, ‘2011-01-12 17:15:43’, ‘dasd’,
34243, ‘2011-01-12 17:15:43’)
SQL (7.8ms) COMMIT
Redirected to http://… (OMITED)
Completed 302 Found in 18ms

Could it be this?
http://lists.rubyonrails.org/pipermail/rails/2006-March/027283.html
It is ancient and I can’t say I understand it, but the log looks very
like yours.

Otherwise I have reached the end of my knowledge span I think.

Colin

Colin L. wrote in post #974329:

On 12 January 2011 15:20, Roger C. [email protected] wrote:

[…]
Yes i’ve also tried the complete source, i am not using javascript and i
upgraded today for Rails 3.0.3 and the problem persists… I just cant
understand why it works when i take the NTLM auth method out of the
picture…

If you look at the app log and compare it between FF and IE what
differences do you see?

You could post the relevant bits of log if appropriate.

Colin

Thks for ur concern Colin. I even created a simple-mini app just using
the standard Rails Scaffold, in order to isolate the problem. And it
still remains. The main difference is that, in FF it passes (besides the
necessary parameteres) the “authenticity_token” and the “commit”.

PS: I had to turn off protect_from_forgery in the
application_controller.rb in order to get it working in IE. Or else i’d
get a “invalid authenticity token”.

Internet Explorer:
Started POST “/people” for xxx at Wed Jan 12 17:15:22 +0000 2011
Processing by PeopleController#create as HTML


** Application Controller :: Authorizer


** PArams: {“action”=>“create”, “controller”=>“people”}
** CREATE
** Params: {“action”=>“create”, “controller”=>“people”}
SQL (0.1ms) BEGIN
SQL (19.7ms) INSERT INTO people (age, created_at, name,
telephone, updated_at) VALUES (NULL, ‘2011-01-12 17:15:22’, NULL,
NULL, ‘2011-01-12 17:15:22’)
SQL (5.6ms) COMMIT
Redirected to http://… (OMITED)
Completed 302 Found in 35ms

FireFox:

Started POST “/people” for xxx at Wed Jan 12 17:15:43 +0000 2011
Processing by PeopleController#create as HTML
Parameters: {“commit”=>“Create Person”, “person”=>{“name”=>“dasd”,
“telephone”=>“34243”, “age”=>“3242”},
“authenticity_token”=>“6U9cHxuI6gW3WPbZoe+i93Tbu+oWjohdv+nuwb/8QXY=”,
“utf8”=>“â”}


** Application Controller :: Authorizer


** PArams: {“commit”=>“Create Person”, “person”=>{“name”=>“dasd”,
“telephone”=>“34243”, “age”=>“3242”},
“authenticity_token”=>“6U9cHxuI6gW3WPbZoe+i93Tbu+oWjohdv+nuwb/8QXY=”,
“utf8”=>“â”, “action”=>“create”, “controller”=>“people”}
** CREATE
** Params: {“commit”=>“Create Person”, “person”=>{“name”=>“dasd”,
“telephone”=>“34243”, “age”=>“3242”},
“authenticity_token”=>“6U9cHxuI6gW3WPbZoe+i93Tbu+oWjohdv+nuwb/8QXY=”,
“utf8”=>“â”, “action”=>“create”, “controller”=>“people”}
SQL (0.1ms) BEGIN
SQL (0.2ms) INSERT INTO people (age, created_at, name,
telephone, updated_at) VALUES (3242, ‘2011-01-12 17:15:43’, ‘dasd’,
34243, ‘2011-01-12 17:15:43’)
SQL (7.8ms) COMMIT
Redirected to http://… (OMITED)
Completed 302 Found in 18ms

Thanks once again.