I have a problem with my virtual block

when i try to go to my website in local like
http://mediawiki.dedibox.fr/, i get the message
It works!

This is the default web page for this server. etc…

but normally i must have my index.php and not that , i don’ t understand
why i get this message .

this is my nginx.conf

*events {
worker_connections 1024;

http {
include mime.types;
passenger_ruby /usr/local/xxxx/ruby-1.9.3-p125/ruby;
passenger_max_pool_size 10;

default_type  application/octet-stream;

sendfile        on;

TCP options

tcp_nopush     on;
tcp_nodelay    on;


keepalive_timeout  65;

types_hash_max_size 2048;
server_names_hash_bucket_size 128;
proxy_cache_path /mnt/donner/nginx/cache levels=1:2 

gzip on;
server_tokens off;

  • include /usr/local/xxx/nginx/vhosts-available/;
    include /usr/local/xxx/nginx/vhosts-available/

server {

  •    listen       80;
      passenger_enabled on;
      passenger_use_global_queue on;
      error_log   /home/logs/nginx/error.log;
      access_log  /home/logs/nginx/access-global.log;


server {

        listen 80 ;
        server_name mediawiki.dedibox.fr;
        root /home/sites_web/mediawiki;
        index index.php index.html;
        error_log  /home/logs/mediawiki/error.log;
        access_log /home/logs/mediawiki/access.log;

location ~ .php$ {

       fastcgi_index index.php;
       fastcgi_param SCRIPT_FILENAME

include /usr/local/centOs/nginx/conf/fastcgi_params;



thank you very much for your help .
And have a good day

Your site is using the default server block in conf.d. There is a
hierarchy in the listen format, looks like the default is above listen
80; simplest way is to either remove the default, or name your site.

i have change the name in the parameter server_name , but i continue to
pointe on It works! etc…

2013/1/14 Steve H. [email protected]

  •       access_log /home/logs/mediawiki/access.log;

nginx mailing list
[email protected]
nginx Info Page


Olivier M.
tel :