I do not configure firebird

I load the fireruby, copy the fbclient.dll for C:\Windows\System32, I
placed in aliases.conf the path for arquive .fdb “testefb =
localhost:C:\Teste\DADOS.FDB” and configure de database.yml:

  1. development:
  2. adapter: firebird
  3. database: testefb
  4. username: sysdba
  5. password: masterkey
  6. host: localhost
  7. test:
  8. development
  9. production:
  10. development

I create a migrate:

  1. def self.up
  2. create_table :usuario do |t|
  3.  t.column :nome, :string, :limit => 30
  4.  t.column :email, :string
  5.  t.column :cript_senha, :string, :null => false
  6.  t.column :nivel, :integer
  7. end
  8. end

And when execute the rake migrate, appear the following error:

rake aborted!
Error opening database connection.
I/O error for file “testefb”
Error while trying to open file
O sistema nÃ’o pode encontrar o arquivo especificado.

Unsuccessful execution caused by a system error that precludes
successful execution of subsequent statements
SQL Code = -902
Firebird Code = 335544344

What I am making a mistake, therefore I tried im my notebook, and on
micro here of work, and both appear the exactly error.

ps.: In aliases.conf I am making to place the path without the
localhost, but appear the following error:

rake aborted!
You have a nil object when you didn’t expect it!
You might have expected an instance of Array.
The error occured while evaluating nil.[]


I have no experience with Firebird, but it looks like you’re running
it in “classic” mode (or that may be what the binding is configured
for) and it wants a database FILE rather than a database CONNECTION.

I suggest reading up on the docs for the binding you’re using:


On 1/2/07, Marcelo J. [email protected] wrote:

  1. host: localhost
  2. create_table :usuario do |t|
    Error opening database connection.
    What I am making a mistake, therefore I tried im my notebook, and on

    Posted via http://www.ruby-forum.com/.

My free Ruby e-book:

My blogs:


I am running in classic, but I tested with super server and also not
executed de rake migrate, appear the exctly message.