I Broke the Console

Oops. I upgraded my Rails installation. I then noticed that the Ruby
was an older version than what I saw on Ruby-lang.org so I download
the MacOS X one-click installer and ran it. It didn’t seem to change
the ruby version, but I decided I didn’t care enough to figure out
why.

Then this morning I tried the console. Oops. I ran the gem installer
again to make sure the Rails installation was okay, or at least that
all the gems were up to date.

Still get the error.

Hints?

Thanks,
–Colin

Coder-iMac:~/Desktop/formr colin$ rails -v
Rails 1.2.5
Coder-iMac:~/Desktop/formr colin$ ruby -v
ruby 1.8.2 (2004-12-25) [universal-darwin8.0]
Coder-iMac:~/Desktop/formr colin$ script/console
Loading development environment.
/usr/lib/ruby/1.8/irb/completion.rb:10:in require': No such file to load -- readline (LoadError) from /usr/lib/ruby/1.8/irb/completion.rb:10 from /usr/lib/ruby/1.8/irb/init.rb:218:inrequire’
from /usr/lib/ruby/1.8/irb/init.rb:218:in load_modules' from /usr/lib/ruby/1.8/irb/init.rb:216:ineach’
from /usr/lib/ruby/1.8/irb/init.rb:216:in load_modules' from /usr/lib/ruby/1.8/irb/init.rb:21:insetup’
from /usr/lib/ruby/1.8/irb.rb:54:in `start’
from /usr/bin/irb:13
Coder-iMac:~/Desktop/formr colin$

i’d probably upgrade to ruby 1.8.5 first

The error is coming from readline lib. Search for hivelogic article on
ror installation

Sent from my iPhone

Okay, I went all the way through the hivelogic installation guide,
which is beautifully written and really clear.

I get:
Coder-iMac:~/Desktop/formr colin$ ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [i686-darwin8.10.3]
Coder-iMac:~/Desktop/formr colin$ rails -v
Rails 1.2.5
Coder-iMac:~/Desktop/formr colin$

But when I tried to run the console it complained:
Coder-iMac:~/Desktop/formr colin$ script/console
Cannot find gem for Rails ~>1.2.4.0:
Install the missing gem with ‘gem install -v=1.2.4 rails’, or
change environment.rb to define RAILS_GEM_VERSION with your
desired version.

So I went into
/usr/lib/ruby/gems/1.8/gems/rails-1.2.4/environments/environment.rb
and set RAILS_GEM_VERSION to be 1.2.5 but that seems pretty silly.

And when I run the server in my application directory (~/Desktop/formr/
script/server) WEBrick starts up and the following is the information
in the default page. (Oh. I don’t see a way to attach something. It
reports 1.8.2 as the Ruby version and 1.2.4 as the Rails version.)

Is this because the formr application was created with 1.2.4 and
there’s some secret way to tell it to look for the new 1.2.5 version?
And why doesn’t it find the new Ruby version yet?

Thanks.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs