I am try to install docker bitnami redmine agile pulgin

[email protected]:~/docker-data/bitnami/redmine/plugins/redmine_agile$ rake redmine:plugins:migrate RAILS_ENV=production --trace
rake aborted!
Don't know how to build task 'redmine:plugins:migrate' (See the list of available tasks with `rake --tasks`)
/var/lib/gems/2.5.0/gems/rake-13.0.1/lib/rake/task_manager.rb:59:in `[]'
/var/lib/gems/2.5.0/gems/rake-13.0.1/lib/rake/application.rb:159:in `invoke_task'
/var/lib/gems/2.5.0/gems/rake-13.0.1/lib/rake/application.rb:116:in `block (2 levels) in top_level'
/var/lib/gems/2.5.0/gems/rake-13.0.1/lib/rake/application.rb:116:in `each'
/var/lib/gems/2.5.0/gems/rake-13.0.1/lib/rake/application.rb:116:in `block in top_level'
/var/lib/gems/2.5.0/gems/rake-13.0.1/lib/rake/application.rb:125:in `run_with_threads'
/var/lib/gems/2.5.0/gems/rake-13.0.1/lib/rake/application.rb:110:in `top_level'
/var/lib/gems/2.5.0/gems/rake-13.0.1/lib/rake/application.rb:83:in `block in run'
/var/lib/gems/2.5.0/gems/rake-13.0.1/lib/rake/application.rb:186:in `standard_exception_handling'
/var/lib/gems/2.5.0/gems/rake-13.0.1/lib/rake/application.rb:80:in `run'
/var/lib/gems/2.5.0/gems/rake-13.0.1/exe/rake:27:in `<top (required)>'
/usr/local/bin/rake:23:in `load'
/usr/local/bin/rake:23:in `<main>'

The problem may be because you are in the plugin directory and not redmine

[email protected]:~/docker-data/bitnami/redmine/plugins/redmine_agile$

try placing yourself in

[email protected]:~/docker-data/bitnami/redmine/$
1 Like

Hi I am use Docker Image file, Please seen below docker file configuration …

version: ‘2’

services:
mariadb:
image: ‘bitnami/mariadb:10.1.38’
environment:
- ALLOW_EMPTY_PASSWORD=yes
volumes:
- ‘~/docker-data/bitnami:/bitnami’
redmine:
image: ‘bitnami/redmine:4.0.1’
ports:
- ‘80:3000’
volumes:
- ‘~/docker-data/bitnami:/bitnami’
depends_on:
- mariadb
volumes:
mariadb_data:
driver: local
redmine_data:
driver: local

Your mistake is when it comes to running

 rake redmine:plugins:migrate RAILS_ENV=production

because you are doing it from the wrong directory, you have to do it from the root of redmine.

try placing yourself in

[email protected]:~/docker-data/bitnami/redmine/$

then run

 rake redmine:plugins:migrate RAILS_ENV=production

Hi Please find attached file my Redmine folder and Docker ymail file screenshot.

Run Redmine Command :- docker-compose up

version: ‘2’

services:
mariadb:
image: ‘bitnami/mariadb:10.1.38’
environment:
- ALLOW_EMPTY_PASSWORD=yes
volumes:
- ‘~/docker-data/bitnami:/bitnami’
redmine:
image: ‘bitnami/redmine:4.0.1’
ports:
- ‘3000:3000’
volumes:
- ‘~/docker-data/bitnami:/bitnami’
depends_on:
- mariadb
volumes:
mariadb_data:
driver: local
redmine_data:
driver: local

[email protected]:~/docker-data/bitnami/redmine# rake redmine:plugins:migrate RAILS_ENV=production
rake aborted!
No Rakefile found (looking for: rakefile, Rakefile, rakefile.rb, Rakefile.rb)
/var/lib/gems/2.5.0/gems/rake-13.0.1/exe/rake:27:in `<top (required)>’
(See full trace by running task with --trace)
[email protected]:~/docker-data/bitnami/redmine#
[email protected]:~/docker-data/bitnami/redmine#

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs