HTTPS with ruby 1.8.4 on Windows?

Hello,

does anybody know, what to do to get HTTPS working with ruby 1.8.4 on
Windows?

I get the error:

RUBY18/lib/ruby/1.8/net/http.rb:565:in connect': undefined methodverify_mode’ for nil:NilClass (NoMethodError)
from I:/PROGRAMS/RUBY18/lib/ruby/1.8/net/http.rb:555:in
do_start' from I:/PROGRAMS/RUBY18/lib/ruby/1.8/net/http.rb:544:instart’
from I:/PROGRAMS/RUBY18/lib/ruby/1.8/net/http.rb:1031:in
request' from I:/PROGRAMS/RUBY18/lib/ruby/1.8/net/http.rb:771:inget’
from K:/ssl3.rb:29

The same error is described here:

http://groups.google.com/group/comp.lang.ruby/browse_frm/thread/7716d
07d7c549c59

Solution there: “Rolling back to a clean, fresh ruby 1.8.2-15”, but I
don’t like to do this… .

For test, I used for example this code:

#-----------------------------
require ‘net/https’

url = URI.parse ‘https://www.wamu.com
server = Net::HTTP.new url.host, url.port
server.use_ssl = url.scheme == ‘https’
server.verify_mode = OpenSSL::SSL::VERIFY_NONE
response = server.get url.request_uri
puts response.code
#-----------------------------

I’m using:

ruby 1.8.4 (2005-12-24) [i386-mswin32], Windows 98SE

Regards,

Axel

This probably doesn’t help you much but your code ran for me
on Windows XP SP2 using two different versions of ruby 1.8.4:

ruby 1.8.4 (2005-12-24) [i386-mswin32]
ruby 1.8.4 (2005-12-26) [i386-cygwin]

(One is compiled with Visual C++ and the other with gcc.)

Your code returned a response status of 302, which is a redirect,
which I believe is the correct response since the https page wants
to redirect to this page: http://www.wamu.com/personal/default.asp.

-lv

Hi

I got the same problem, same error, works with 1.8.2 doesn’t with 1.8.4

Did you find the problem?

Robert

Did you find the problem?

Unfortunately, no.

Axel

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs