HTTP 400 error when using Aptana IDE, Webrick and Rails with Vista and IE7

Hi,

I have a strange problem that appears to be a problem with redirect_to
with the following software combination.

Vista Business
IE7
Aptana IDE and Webrick
Rails 1.8.6

I have a user controller with a login method, such as :

def login

Handle posted stuff here

Find user name and login

A raise user.inspect here works

user=find_by_username…
redirect_to :action => ‘index’
end

def index

A raise user.inspect here is never reached

Do some stuff here

end

At some point, assuming it is around the redirect_to command, the
webrick console in Aptana reports an invalid exception ‘’ and and HTTP
400 error. This error is echoed by IE7.

I’m running Rails 1.8.6, with a Webrick server setup under Aptana.
The underlying operating systems is Vista business with IE7. This
problem has started happening in the last week, even on code that has
not been changed in that time.

I’ve tried the following;

  1. Running Mozilla on the same PC, this works OK so I guess my
    application is OK.
  2. Using another PC to access the application on my Vista PC. Both
    IE7 (on XP) and Mozilla on this 2nd PC work OK.

Therefore, I’m assuming it is something to do with my PC, with either
Vista or IE7 causing the problem.

I’ve also tried;

  1. Increasing the logging level of webrick to see exactly what the
    request is, but haven’t found a way to do this. Setting the server to
    debug doesn’t provide any more information in the console of the
    development log.
  2. Removing the patches that vista has installed over the past week.
  3. Searching the internet for any similar problems.

Has anyone seen this before? Does anybody have any ideas on:

  1. How to show the actual request coming in from the browser to the
    webrick server so that I can compare the differences between IE7 (on
    Vista) and IE7 (on XP) and Mozilla (on Vista/XP)
  2. What might be the cause of this?

All help is greatfully received! I don’t want to launch a site that
says “Not for Vista” on the homepage! :frowning:

Thanks

Mark.

I’ve fixed this now by backing up my projects, uninstalling Aptana IDE
and Ruby, then reinstallating Ruby and Aptana and re-importing my
projects.

Hope this helps someone in the future!

Mark.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs