Howto gem thru a proxy

high

my problem was the following:

H:>gem search bla --remote

*** REMOTE GEMS ***
ERROR: While executing gem … (Errno::EBADF)
Bad file descriptor - connect(2)

a long time i could not figure out, why this happens - though i had
the intention, it must be, because i only can go thru a proxy to the i-
net. so, here is finally the solution, if you suffer the same
circumstances.

  1. find out, what your proxy url is (in your functioning browsers
    options you will find something like a http://terra.sol.org/proxy.pac;
    donwload this, open in an editor an find your proxy-server url)

  2. assuming your proxys url is: http://terra.sol.proxy.org:8080, set
    an environment variable called http_proxy to that url:

open a shell/command-window an do:

REALOS> export http_proxy=http://terra.sol.proxy.org:8080
NOOS> set http_proxy=http://terra.sol.proxy.org:8080
ANYOS> gem install fxri

thats it

have fun!

unknown wrote:

high

my problem was the following:

H:>gem search bla --remote

*** REMOTE GEMS ***
ERROR: While executing gem … (Errno::EBADF)
Bad file descriptor - connect(2)

  1. find out, what your proxy url is (in your functioning browsers
    options you will find something like a http://terra.sol.org/proxy.pac;
    donwload this, open in an editor an find your proxy-server url)

  2. assuming your proxys url is: http://terra.sol.proxy.org:8080, set
    an environment variable called http_proxy to that url:

open a shell/command-window an do:

REALOS> export http_proxy=http://terra.sol.proxy.org:8080
NOOS> set http_proxy=http://terra.sol.proxy.org:8080
ANYOS> gem install fxri

thats it

have fun!

hi,
i tried the above solution. but still i get the same error

Does this work for you:

gem query --remote --name-matches doom -p
http://terra.sol.proxy.org:8080
where:
http://terra.sol.proxy.org:8080” is :

I took it from here:
http://docs.rubygems.org/read/book/1

and:
http://docs.rubygems.org/read/chapter/13#page51

–Axel

unknown wrote:

high

my problem was the following:

H:>gem search bla --remote

*** REMOTE GEMS ***
ERROR: While executing gem … (Errno::EBADF)
Bad file descriptor - connect(2)

a long time i could not figure out, why this happens - though i had
the intention, it must be, because i only can go thru a proxy to the i-
net. so, here is finally the solution, if you suffer the same
circumstances.

  1. find out, what your proxy url is (in your functioning browsers
    options you will find something like a http://terra.sol.org/proxy.pac;
    donwload this, open in an editor an find your proxy-server url)

  2. assuming your proxys url is: http://terra.sol.proxy.org:8080, set
    an environment variable called http_proxy to that url:

open a shell/command-window an do:

REALOS> export http_proxy=http://terra.sol.proxy.org:8080
NOOS> set http_proxy=http://terra.sol.proxy.org:8080
ANYOS> gem install fxri

thats it

have fun!

To install gems behind a proxy server just append at the end " -p
http://proxy.myserver.lan:8080",
where proxy.myserver.lan is your proxy address (check this from your
browser settings).

For example to install the “rails” gem behind
http://proxy.myserver.lan:8080” i’ll use:
##########

gem install rails -p http://proxy.myserver.lan

#########

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs