How to use Trackbacks in r1039


#1

I am trying to get trackbacks to work in my r1039. I installed the patch
from the link below and I see the trackback field when posting, but I
don’t see my comment in the blog which I sent the trackback. The blog
I’m
trying to send trackbacks supports them.

This is the patch (I also updated it)
http://ruby.tower-net.de/index.html/articles/2006/05/02/typo-patch-trackback-support

Is it anybody able to explain me how it works?

Thanks

Thomaz L.
thomaz[at]thomazleite.com (Email, Jabber)


#2

Thomaz L. wrote:

I am trying to get trackbacks to work in my r1039. I installed the patch
from the link below and I see the trackback field when posting, but I
don’t see my comment in the blog which I sent the trackback. The blog I’m
trying to send trackbacks supports them.

This is the patch (I also updated it)
http://ruby.tower-net.de/index.html/articles/2006/05/02/typo-patch-trackback-support

Which patch have you used? I’ve done some changes on May 3rd… There is
a patch for r1039 and a patch to this patch which repairs Quickpost.

Is it anybody able to explain me how it works?

Well, enable trackback (settings) and enter the “trackback uri” in the
textfield at article post. It should work.

You can have a look at your logfile. There should be entries with
“Trackbacks:” and “Processing ArticlesController#trackback”.


#3

Yes, I am using the 1039-patch1, although I’m not writing posts using
quick post.

I enabled trackbacks in settings and when posting, I open the “add
trackback” textfield and enter a trackback url for a second post in my
blog, I also add a link to this second post in the “Article” field.

I noticed when I try to edit the post, the Trackback url is not saved,
and
the trackback textfield is empty. However this is not so important, the
problem is that there are no trackbacks in the post which I sent them.

I also noticed that I have a post with a trackback url saved, although
it’s not a real trackback url, and I cannot delete it. When I save the
post and go back to edit it, the url I removed is still there.

On Fri, May 5, 2006 07:18, Markus K. wrote:

Which patch have you used? I’ve done some changes on May 3rd… There is


Typo-list mailing list
removed_email_address@domain.invalid
http://rubyforge.org/mailman/listinfo/typo-list


Thomaz L.
thomaz[at]thomazleite.com (Email, Jabber)


#4

On Fri, 05 May 2006 12:37:45 -0400, Thomaz L. wrote:

Yes, I am using the 1039-patch1, although I’m not writing posts using
quick post.

I enabled trackbacks in settings and when posting, I open the “add
trackback” textfield and enter a trackback url for a second post in my
blog, I also add a link to this second post in the “Article” field.

Do you talk about “Enable trackbacks by default” or “Send trackbacks to
external sites”?
The textfield for external site urls is optional. This url textfield is
for sites you want to notice about every change on your blog. Check
the box and make the textfield empty if you only want to do it article
based.

I noticed when I try to edit the post, the Trackback url is not saved, and
the trackback textfield is empty. However this is not so important, the
problem is that there are no trackbacks in the post which I sent them.

Do you really use a trackback url and not the article url (permalink)?

I also noticed that I have a post with a trackback url saved, although
it’s not a real trackback url, and I cannot delete it. When I save the
post and go back to edit it, the url I removed is still there.

Ok, this is another bug. I wouldn’t bet how many bugs are in this patch.
Maybe I should do a rewrite.
But with correct trackback url it works here.

You can have a look at your logfile. There should be entries with
“Trackbacks:” and “Processing ArticlesController#trackback”.

Please have a look at your logfile for these two strings and post the
lines following them. It’s very difficult to say what’s going wrong
there
without an idea what’s going on.


#5

Thomaz L. wrote:

On Fri, May 5, 2006 14:00, Markus K. wrote:

[…]

Ok, this is another bug. I wouldn’t bet how many bugs are in this patch.
Maybe I should do a rewrite.
But with correct trackback url it works here.

Ok if it’s a bug. But when using correct trackback urls, this problem
remains.

I’ve read more code and it’s not really a bug. The original patch coder
has forgotten to tell that his patch wasn’t finished ;(
It depends on the settings if it works or not.
I try to finish it in the next days.


#6

On Fri, May 5, 2006 14:00, Markus K. wrote:

external sites"?
The textfield for external site urls is optional. This url textfield is
for sites you want to notice about every change on your blog. Check
the box and make the textfield empty if you only want to do it article
based.

I am talking about enable trackbacks by default. The textfield for
external sites contains only urls of sites such as technorati.

I noticed when I try to edit the post, the Trackback url is not saved,
and
the trackback textfield is empty. However this is not so important, the
problem is that there are no trackbacks in the post which I sent them.

Do you really use a trackback url and not the article url (permalink)?

Yes, I’m using a trackback url, not the permalink.

I also noticed that I have a post with a trackback url saved, although
it’s not a real trackback url, and I cannot delete it. When I save the
post and go back to edit it, the url I removed is still there.

Ok, this is another bug. I wouldn’t bet how many bugs are in this patch.
Maybe I should do a rewrite.
But with correct trackback url it works here.

Ok if it’s a bug. But when using correct trackback urls, this problem
remains.

You can have a look at your logfile. There should be entries with
“Trackbacks:” and “Processing ArticlesController#trackback”.

Please have a look at your logfile for these two strings and post the
lines following them. It’s very difficult to say what’s going wrong there
without an idea what’s going on.

Sorry from my part for not sending the log entries. Here they are:

Trackbacks: [“http://blog.thomazleite.com/articles/trackback/6”]
article: send_pings(“http://blog.thomazleite.com/”,
http://blog.thomazleite.com/articles/2006/05/05/teste-de-trackback”,
[“http://blog.thomazleite.com/articles/trackback/6”])
Pinging http://rpc.technorati.com/rpc/ping
Pinging http://ping.blo.gs/
Pinging http://rpc.weblogs.com/RPC2
Pinging
http://blog.thomazleite.com/articles/2006/05/05/livro-sobre-ruby--em-pt_br

Processing ArticlesController#trackback (for 66.249.66.212 at 2006-05-05
19:21:29) [GET]
Session ID: 2851c271f17385e41e43ccab3068795c
Parameters: {“action”=>“trackback”, “id”=>“6”,
“controller”=>“articles”}
Rendering articles/trackback
Completed in 0.09347 (10 reqs/sec) | Rendering: 0.08588 (91%) | DB:
0.00452 (4%) | 200 OK [http://thomazleite.com/articles/trackback/6]


Thomaz L.
thomaz[at]thomazleite.com (Email, Jabber)


#7

Hello Thomaz,

can you try these two additional patches…
http://ruby.tower-net.de/typo/typo_trackbacks_svndiff-1039_patch2.diff
http://ruby.tower-net.de/typo/typo_trackbacks_svndiff-1039_patch3.diff

There is now a warning about each failed ping. But I am not sure if this
is an good idea for the urls in the article body. Should I enable the
warnings only for the urls in trackback textarea? What do you think?

Do you know an url with pingback support (X-Pingback header/pingback
link tag) where I can test that part?

Update May 07 2006:

Here is an additional patch: typotrackbackssvndiff-1039_patch2.diff

Known issues:

  1. Pings are sent on each article edit
    typotrackbackssvndiff-1039_patch3.diff

Changes:

  1. Reports failed ping urls
  2. Supports adding new trackbacks on article edit
  3. Supports pingbacks (untested) and trackbacks from normal urls in
    the article text body

Note:

Using urls in body with pingback or trackback support and adding a
trackback for the same target results in 2 pings to the same target.