How to upgrade to Ruby1.8-3?


#1

Hi, I already installed Ruby 1.8-2 but I’d like to upgrade to 1.8-3
because of the security hole. Unfortunately the compilation from source
fails and the only RPM that I found is not good on my distro.

Is there an easy way to upgrade Ruby? Maybe through gems?

Thanks.


#2

On 11/21/05, Tony removed_email_address@domain.invalid wrote:

Is there an easy way to upgrade Ruby? Maybe through gems?

Not really. If you post your compilation troubles, we might be able to
help.


#3

On Nov 21, 2005, at 7:22 PM, Tony wrote:

Hi, I already installed Ruby 1.8-2 but I’d like to upgrade to 1.8-3
because of the security hole.

Just my experience, but 1.8.3 cause me nothing but pain. I had
trouble with Rake, Rails, RubyGems/RubyForge, YAML, and the
documentation after I upgraded. I fixed as many issues as I could,
then finally gave up and downgraded back to 1.8.2. I can only hope
you would have a better experience, but with 1.8.4 due next month, it
might be worth waiting…

James Edward G. II


#4

On Monday 21 November 2005 19:26, Jacob Quinn S. wrote:

On 11/21/05, Tony removed_email_address@domain.invalid wrote:

Is there an easy way to upgrade Ruby? Maybe through gems?

Not really. If you post your compilation troubles, we might be able to
help.

sudo apt-get install ruby1.8

But that’s only on debian based distros. And will only upgrade you if
you
need it. If you’re on RPMs then yuck, and you’re kinda out of luck
unless
you can find someone that wrapped it up for your specific distro.


#5

Kevin B. wrote:

But that’s only on debian based distros. And will only upgrade you if you
need it. If you’re on RPMs then yuck, and you’re kinda out of luck unless
you can find someone that wrapped it up for your specific distro.

My distro has both apt-get and RPMs. However the list of apt-get looks
like the same of RPMs. Is there a way how to tell apt-get to go get the
file on a certain external/remote server?

Thanks.


#6

On Monday 21 November 2005 19:47, Tony wrote:

Kevin B. wrote:

But that’s only on debian based distros. And will only upgrade you if
you need it. If you’re on RPMs then yuck, and you’re kinda out of luck
unless you can find someone that wrapped it up for your specific distro.

My distro has both apt-get and RPMs. However the list of apt-get looks
like the same of RPMs. Is there a way how to tell apt-get to go get the
file on a certain external/remote server?

Thanks.

/etc/apt/sources.list is probably what you’re looking for.


#7

James Edward G. II wrote:

Just my experience, but 1.8.3 cause me nothing but pain. I had trouble
with Rake, Rails, RubyGems/RubyForge, YAML, and the documentation after
I upgraded. I fixed as many issues as I could, then finally gave up
and downgraded back to 1.8.2. I can only hope you would have a better
experience, but with 1.8.4 due next month, it might be worth waiting…

Thank you for letting me know this, James. I’ll wait a month or two! :slight_smile:


#8

You’ll probably need
apt-get -t testing install ruby1.8

The stable version of the package has ruby 1.8.2, testing is 1.8.3.

Also worth noting that the stable package is 1.8.2-7sarge2, so it’s
been patched twice and may have the security hole covered… (I’ve not
read the release notes).


#9

On Wednesday 23 November 2005 02:12, Jeremy H. wrote:

In article removed_email_address@domain.invalid,

James Edward G. II wrote:

Just my experience, but 1.8.3 cause me nothing but pain. I had
trouble with Rake, Rails, RubyGems/RubyForge, YAML,

I was bugged by YAML problems too so I upgraded to a recent stable
snapshot and everything was fine. I can’t say whether Rake, Rails,
RubyGems/RubyForge are OK since I don’t use them, but YAML is already
fixed AFAICT.

I use YAML pretty extensively in my app, and when I upgraded to 1.8.3
(using
apt-get on a Kubuntu system) everything was fine, so it appears that at
least
the Ubuntu repositories have incorporated a fix.


#10

In article removed_email_address@domain.invalid, Kevin B. wrote:

On Wednesday 23 November 2005 02:12, Jeremy H. wrote:

I was bugged by YAML problems too so I upgraded to a recent stable
snapshot and everything was fine.

I use YAML pretty extensively in my app, and when I upgraded to
1.8.3 (using apt-get on a Kubuntu system) everything was fine,

Do you set “$VERBOSE = true”? My problem was that “$VERBOSE = true ;
require yaml” spewed a lot of warnings in 1.8.3 . It didn’t break
anything but the noise was very annoying. If you don’t set “$VERBOSE
= true” then probably 1.8.3 is fine.

Jeremy


#11

In article removed_email_address@domain.invalid,
James Edward G. II wrote:

Just my experience, but 1.8.3 cause me nothing but pain. I had
trouble with Rake, Rails, RubyGems/RubyForge, YAML,

I was bugged by YAML problems too so I upgraded to a recent stable
snapshot and everything was fine. I can’t say whether Rake, Rails,
RubyGems/RubyForge are OK since I don’t use them, but YAML is already
fixed AFAICT.

Cheers,

Jeremy H.