How to setup sybase adapter on Windows xp?


#1

Environment : rails 1.2.6 , ruby 1.8.6 , Windows xp
I tried to use the command (gem install activerecord-sybase-adapter)
to install my adapter, but I got this error message.

“database configuration specifies nonexistent sybase adapter
(ActiveRecord::AdapterNotFound)”

Then, I try to follow this article in
http://wiki.rubyonrails.com/rails/pages/SybaseASEonWin32
and download sybase-ctlib file.
Now I want to setup the build script but I don’t know how to modify
it.
I dont’ want to use VS.NET 2003/2005. Can I delete te following
command lines?

rem VS.NET 2003
rem set VC=C:\Program Files\Microsoft Visual Studio .NET 2003\Vc7

rem VS.Net 2005
set VC=C:\Program Files\Microsoft Visual Studio 8\VC

My Sybase ASE 12.5 was installed on a remote computer. How to modify
it?

rem ASE 12.5
set SYBASE=?
set OSC=OCS-12_5
set LIBS=libct.lib libcs.lib

Thanks for any hint!

Regard,

LJ