How to set up SPDY Protocol over Nginx?

Hi Guys

I am having problem setting up the SPDY protocol for my rails app over
nginx. Here is the complete detail of the setup on stacjoverflow.

http://stackoverflow.com/questions/15152775/how-to-set-up-spdy-protocol-over-nginx

Posting it here so that it can have a bigger audience.

I can copy paste the entire question here if it in inconvenient to
follow
stackoverflow link.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,236756,236756#msg-236756

On Friday 01 March 2013 12:11:15 deepak-kumar wrote:

I can copy paste the entire question here if it in inconvenient to follow
stackoverflow link.

Most likely you are trying to run a different version of nginx, not one
that
you have built with spdy.

wbr, Valentin V. Bartenev


http://nginx.com/support.html
http://nginx.org/en/donation.html

On Friday 01 March 2013 13:39:04 deepak-kumar wrote:

Well thats possible. But Nginx -V gives me correct version and shows that
SPDY module is enabled and configured …

When I do which nginx on terminal it returns /usr/local/sbin/nginx

Can you tell me how can I check which binary is being used for the app?

How do you start it?

wbr, Valentin V. Bartenev


http://nginx.com/support.html
http://nginx.org/en/donation.html

Well thats possible. But Nginx -V gives me correct version and shows
that
SPDY module is enabled and configured …

When I do which nginx on terminal it returns /usr/local/sbin/nginx

Can you tell me how can I check which binary is being used for the app?

$ nginx -V

nginx version: nginx/1.3.13
built by gcc 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
TLS SNI support enabled
configure arguments: --sbin-path=/usr/local/sbin/nginx
–prefix=/etc/nginx
–conf- path=/etc/nginx/nginx.conf
–error-log-path=/var/log/nginx/error.log
–http-client-body-temp-path=/var/lib/nginx/body
–http-fastcgi-temp-path=/var/lib/nginx/fastcgi
–http-log-path=/var/log/nginx/access.log
–http-proxy-temp-path=/var/lib/nginx/proxy
–http-scgi-temp-path=/var/lib/nginx/scgi
–http-uwsgi-temp-path=/var/lib/nginx/uwsgi
–lock-path=/var/lock/nginx.lock
–pid-path=/var/run/nginx.pid --with-debug --with-http_addition_module
–with-http_dav_module --with-http_gzip_static_module
–with-http_realip_module --with-http_stub_status_module
–with-http_ssl_module --with-http_sub_module --with-http_xslt_module
–with-http_spdy_module --with-ipv6 --with-sha1=/usr/include/openssl
–with-md5=/usr/include/openssl --with-mail --with-mail_ssl_module
–add-module=/software/ngx_cache_purge-1.6
–with-openssl=/software/openssl-1.0.1e

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,236756,236763#msg-236763

Thanks for the hint. I had to change my init.d script.

Modified to
DAEMON=/usr/local/sbin/nginx

earlier it was #DAEMON=/usr/sbin/nginx

CLOSED.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,236756,236777#msg-236777

Yeah. I get your point. I ll post my findings here.

Thanks.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,236756,236772#msg-236772

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs