How to set RUBYLIB path?

Dear all,

I was struggling with a problem. I have a product class and a test file
under Merchant folder. when i run my product class it shows following
error.

c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require': no such file to load -- builder (LoadError) from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from product.rb:2

I need to set path like set RUBYLIB = “”

i didnt got how to set the path and in which file i have to set or in
shell prompt? how to set path?

Could any one help me to solve this problem of setting path.

Thanks in advance

Regards,
Martin

maybe gem install builder?
if not maybe google for ‘rubygems path’ and ‘RUBYLIB environment
variable’

On Fri, Apr 18, 2008 at 7:38 AM, dare ruby [email protected]
wrote:

from product.rb:2
Regards,
Martin

Posted via http://www.ruby-forum.com/.

There are basically three possibilities let us say your library is here:
/lib/mylibs/mylibrary.rb
(1)
setting the variable
export RUBYLIB="/lib/mylibs/${RUBYLIB:-""}"
(2)
using a command line option
ruby -I/lib/mylib myprog.rb
(3)
adjust your $: inside your ruby program
$:.unshift File.join( %w{ /lib mylib } )

HTH
Robert


http://ruby-smalltalk.blogspot.com/


Whereof one cannot speak, thereof one must be silent.
Ludwig Wittgenstein

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs