How to set content_transfer_encoding to something other than quoted-printable?

Hi all,

How do I set the content_transfer_encoding for mail with actionmailer
to something other than quoted-printable? It’s a setting with TMail
which action mailer relies on in rails 2.3.*. I am trying to set it to
utf8

I have tried:

  • mail = TMail::Mail.new; mail.transfer_encoding = “utf8”;
  • setting the @header[“Content-Transfer-Encoding”] in the mailer’s
    delivery method
  • various combinations of ActionMailer::Base.transfer_encoding = ,
    content_transfer_encoding =, [:content_transfer_encoding], etc
  • all kinds of other craziness with encoding/decoding attempts

There is a comment here that there is a setting in the docs:
http://www.ruby-forum.com/topic/172132#755189, but I cannot find it.

Anyone have any ideas? Anything is welcome. This one I’ve been stuck
on for 5 hours now.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs