How to set '302 Moved' location protocol


#1

Same problem, but hopefully a clearer call for help :wink:

I need to set the protocol part of the Location: in the ‘302 Moved’
header to ‘https:’. I can see in Live HTTP Headers that it’s currently
set to ‘http:’. This is causing warning dialogs (‘you’re being
redirected to an unsecured page’) under SSL for all my controller to
controller redirect_to’s. Is this something I can set in Rails? Or is
it something that gets set somewhere else (like Apache, maybe?).

Thanks much for any help!!!

Best regards,
Bill


#2

On 3/9/07, Bill W. removed_email_address@domain.invalid wrote:

Thanks much for any help!!!

Best regards,
Bill

There are a ton of discussions already on this – this was at the top
of google’s list:

http://blog.duncandavidson.com/2006/01/reverse_proxyin.html
also
http://dev.rubyonrails.org/ticket/5346

  • Rob

#3

Hi Rob,

First, thank you very much for your reply. I really appreciate it and,
after taking a quick look at the first link, am feeling pretty sure
it’ll
help me figure out what I need to do. Second thing is, I have no idea
wtf a
‘reverse proxy’ is. Which is why I’m so very thankful to Robby for
setting
this list up to begin with.

Thanks again for your reply. At least now I have something to Google on.
Damn tough to find an answer when you can’t even form a good question
:wink:

Best regards,
Bill