How to make guard use polling on Snow Leopard

I can’t seem to get Guard 1.0.0 and rb-fsevent 0.9.0 or 0.4.3.1 to
talk to each other. Is there a way to get Guard to use polling instead
of rb-fsevent? I was on 10.6.6. Updating to 10.6.8 did not help. I
updated my XCode to 3.2.6 and that did not help.

I ran a utility called fseventmon that seems to show that the fs
events are happening:

/usr/local/bin/fseventsmon .
Monitoring …
/Users/dwormuth/sites/rails/wiz/app/models/ (None)
/Users/dwormuth/sites/rails/wiz/app/models/ (None)
/Users/dwormuth/sites/rails/wiz/app/models/ (None)
/Users/dwormuth/sites/rails/wiz/app/models/foo/ (None)
/Users/dwormuth/sites/rails/wiz/app/models/foo/ (None)
/Users/dwormuth/sites/rails/wiz/app/models/ (None)
/Users/dwormuth/sites/rails/wiz/app/models/ (None)
/Users/dwormuth/sites/rails/wiz/app/models/ (None)
/Users/dwormuth/sites/rails/wiz/app/models/ (None)

Any thoughts?

From the Guard maintainer:

Use Bundler and do not add the rb-fsevent gem to your Gemfile,
then start Guard with the --no-vendor option to let it ignore the
vendor gem.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs