How to lock Typo to Rails 1.0?

My hosting provider has upgraded to Rails 1.1 without any warning and
it looks like all of the hosted Typo installs are down :frowning:

I tried adding the following to config/environment.rb at the top of
the file, but by that point the Rails 1.1 libraries have already been
loaded (not sure how as the calling script is dispatch.fcgi):

require ‘rubygems’
require_gem ‘activesupport’, ‘= 1.3.0’
require_gem ‘activerecord’, ‘= 1.13.2’
require_gem ‘actionpack’, ‘= 1.11.2’
require_gem ‘actionmailer’, ‘= 1.1.5’
require_gem ‘actionwebservice’, ‘= 1.0.0’

So, where should I lock-down the gems to the Rails 1.0 versions?

Thanks,
Sean

/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:149:in activate': can't activate activesupport (= 1.2.5), already activated activesupport-1.3.0] (Gem::Exception) from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:167:inactivate’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:166:in each' from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:166:inactivate’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:37:in
require_gem_with_options' from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:31:inrequire_gem’
from …/typo/public/…/config/environment.rb:8
from …/typo/public/dispatch.fcgi:21:in `require’
from …/typo/public/dispatch.fcgi:21

svn export http://dev.rubyonrails.org/svn/rails/tags/rel_1-0-0/ vendor/rails from your RAILS_ROOT is supposed to do the trick, but
it’s still not working for my on Dreamhost. I’d give it a try. It
should work.

Try running:

rake freeze_edge REVISION=3303

On your Typo install directory. This is the equivalent to the Rails
1.0gem.

-Steve
http://www.stevelongdo.com

Hi,

I am not sure if this will be at all helpful, but my typo install on
dreamhost seems to be working just fine, in spite of the rails 1.1
upgrade. I do run a pretty old revision on it though,
r760. Maybe it help figuring out where the problems are, if they are
not already known.

Robert

never mind. old processes were still running…

Thanks!

This worked great on Textdrive for me.

And, strangely, I seem to be consuming less memory.

Thanks,
Nick

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs