How to install Rails stand-alone?

Hello friends,
I am assigned the task to learn Rails. But my company firewall
prevents the gems update through net and it is not possible. Hence I
downloaded
rails-1.1.6.zip. But it doesn’t have anything like setup or no document
on how to install it. I am searching the net also, but none is giving
about stand-alone, all are giving a round about answer as Instant rails.

So Can someone, let me know how to proceed further(install) in
stand-alone package? Thanks in advance.

all are giving a round about answer as Instant rails.

In an environment like your I would also suggest InstantRails to learn.
It’s simply briliant and couldn’t be easier to use:
http://instantrails.rubyforge.org/wiki/wiki.pl

…or are there any specific reason why you don’t want to use
InstantRails?

Stefan wrote:

all are giving a round about answer as Instant rails.

In an environment like your I would also suggest InstantRails to learn.
It’s simply briliant and couldn’t be easier to use:
http://instantrails.rubyforge.org/wiki/wiki.pl

…or are there any specific reason why you don’t want to use
InstantRails?

Yes, Stefan stand-alone is 2.6MB as against InstantRails at 58MB

S.Kumar wrote:

Stefan wrote:

all are giving a round about answer as Instant rails.

In an environment like your I would also suggest InstantRails to learn.
It’s simply briliant and couldn’t be easier to use:
http://instantrails.rubyforge.org/wiki/wiki.pl

…or are there any specific reason why you don’t want to use
InstantRails?

Yes, Stefan stand-alone is 2.6MB as against InstantRails at 58MB

Yes but that includes Ruby, Rails, MySQL, Apache, PHP and some more. I
guess a 58MB can be a hefty download if on dial-up though.

I have installed rails from the downloaded gem so I know it works but
can’t remember the steps. I’ll see if I can look into it.

S.Kumar wrote:

Hello friends,
I am assigned the task to learn Rails. But my company firewall
prevents the gems update through net and it is not possible. Hence I
downloaded
rails-1.1.6.zip. But it doesn’t have anything like setup or no document
on how to install it. I am searching the net also, but none is giving
about stand-alone, all are giving a round about answer as Instant rails.

So Can someone, let me know how to proceed further(install) in
stand-alone package? Thanks in advance.

Download the Rails gem instead of the .zip. Then install like this:

$ gem install rails-1.1.6.gem --local

Rails has a number of dependencies that you’ll need to download as gems
and install as well. activerecord, active-support, etc. You can probably
find the listing on rubyforge.org. Just download and install the gems
the same way. You could have them install automatically with
–include-dependencies, but then it would try to fetch them from the net
which wouldn’t work for you.

Of course you have to have rubygems installed, which you can get from
rubyforge.org

(This is assuming you’re using *nix. If you’re running Windows, I have
no idea.)

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs