How to install, and use "tidy" gem


#1

Hi,

Ruby newbie here.

I’m trying to install the gem tidy so that it can be used as a filter by
webby.

I thought it was “gem install tidy” - but this tells me it is
installed. - version 1.1.2!

There is a comment on the user maual
(http://webby.rubyforge.org/user-manual/) that reads “The HTML Tidy
application must be installed on your system, and the |tidy| executable
must be available on the path.”.

What does that mean? I can find no tidy.exe or tidy,com.

However webby tells me that tidy is not installed. (and Tidy is
unknown).

So after gem has failed to make the gem available, what do I have to
move where?

I tried copying C:/ruby/lib/ruby/gems/1.8/gems/tidy-1.1.2/lib/tidy.rb
cid:removed_email_address@domain.invalid /ruby/bin/tidy.rb but that
hasn’t sorted the problem

Thanks for your help.

Ian


#2

Ian H. wrote

Darn message was munged by Thunderbird and yours truly!

The copy was from

C:/ruby/lib/ruby/gems/1.8/gems/tidy-1.1.2/lib/tidy.rb
to
/ruby/bin/tidy.rb

c:\ruby\bin is on my path.

Ian


#3

Robert K. wrote:

robert

Thanks Robert,

All working now :slight_smile: I guess I confused the tidy gem with html tidy.

Regards

Ian


#4

On 01.02.2009 20:06, Ian H. wrote:

What does that mean? I can find no tidy.exe or tidy,com.

I’d say you need http://tidy.sourceforge.net/ installed on your system -
as the documentation says.

Cheers

robert


#5

On Mon, Feb 2, 2009 at 7:56 PM, Ian H. removed_email_address@domain.invalid
wrote:

as the documentation says.

Cheers

robert

Thanks Robert,

All working now :slight_smile: I guess I confused the tidy gem with html tidy.

Please watch out if you are using this in a long-running process, as
the tidy gem has a memory leak.

^ manveru