How to get rdoc documentation with merb_generator?


#1

Hi all,

Our company spent a year programming with hardly any documentation. I’ve
spent the last two weeks adding this in rdoc format to the controller
and various library files. So now I need to generate the actual
documentation. I ran into some trouble:-

Our app has two branches historically. The older one has apps for which
merb-gen generated an empty ‘doc’ directory (well, I don’t know if it
was completely empty, but it gave me no issues). So I could run rdoc in
the branch root and this generated documentation smoothly in ‘doc/rdoc’
no problem. GOOD!

The newer branch has apps for which merb-gen generated a doc directory
containing ‘rdoc’ and ‘rdoc/generators’ where there is a
‘merb_generator.rb’ file. Now when I try to run rdoc from the branch
root I get an error message telling me to specify the rdoc target
directory to avoid overwriting existing documentation (currently there
isn’t any, see below). OOPS!

So I wonder how can doc/rdoc/generators/merb_generator.rb be used to do
the job instead (which I assume is why it is generated by merb-gen)…

Reading the source code was interesting but unhelpful for my level of
understanding of merb’s structure. I tried to run it with merb -r
without any effect. Also I could not find a single tutorial or
documentation online in the merb site, merbist, or dozens of
merb-related blogs. Hmmm, I think I am missing something so basic
everyone knows it!

Any help appreciated. Many thanks in advance,
Gernot