How to build with proper readline version


#1

Hello,

I am trying to build Ruby 1.9 on Mac OSX x86 Tiger. This first requires
an update to readline.

I have updated my readline but installed it to /usr/local since I do not
want to update the original binaries.

The problem is the configure script is trying to use the one in /usr/bin
and I don’t know how to tell it otherwise.

The option --with-readline-dir=/usr/local sprinkled all over the web
does nothing as there is no such option in the configure script
(specifically it leads to an unrecognized option warning). I have tried
3 of the different 1.9.x releases all with the same result.

Any suggestions?

thanks


#2

Hello,

On 2009/01/11, at 8:56, Mark F. wrote:

I am trying to build Ruby 1.9 on Mac OSX x86 Tiger. This first requires
an update to readline.
(snip)
The option --with-readline-dir=/usr/local sprinkled all over the web
does nothing as there is no such option in the configure script
(specifically it leads to an unrecognized option warning). I have tried
3 of the different 1.9.x releases all with the same result.

I am current readline mainteinar.
I run the configure script with ‘–with-readline-dir=/sw’.
‘/sw’ is the Fink’s readline installed directory.

My readline.bundle is linked /sw/lib/libreadline.4.dylib.

ragdoll$ otool -L
~/local/lib/ruby/1.9.0/i386-darwin9.5.0/readline.bundle
/Users/kouji/local/lib/ruby/1.9.0/i386-darwin9.5.0/readline.bundle:
/sw/lib/libreadline.4.dylib (compatibility version 4.2.0,
current version 4.3.0)
/sw/lib/ncurses/libncurses.5.dylib (compatibility version 5.0.0,
current version 5.0.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current
version 111.1.1)
/usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current
version 227.0.0)
/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current
version 1.0.0)

Thanks.


#3

Well I run the configure script with ‘–with-readline-dir=/usr/local’
and I get:

configure: WARNING: unrecognized options: --with-readline-dir

–and I get this with whatever I specify as the directory (which I think
is because there is no such option in the configure script).

I have tried with every 1.9.x distro.

Takao K. wrote:

Hello,

On 2009/01/11, at 8:56, Mark F. wrote:

I am trying to build Ruby 1.9 on Mac OSX x86 Tiger. This first requires
an update to readline.
(snip)
The option --with-readline-dir=/usr/local sprinkled all over the web
does nothing as there is no such option in the configure script
(specifically it leads to an unrecognized option warning). I have tried
3 of the different 1.9.x releases all with the same result.

I am current readline mainteinar.
I run the configure script with ‘–with-readline-dir=/sw’.
‘/sw’ is the Fink’s readline installed directory.

My readline.bundle is linked /sw/lib/libreadline.4.dylib.

ragdoll$ otool -L
~/local/lib/ruby/1.9.0/i386-darwin9.5.0/readline.bundle
/Users/kouji/local/lib/ruby/1.9.0/i386-darwin9.5.0/readline.bundle:
/sw/lib/libreadline.4.dylib (compatibility version 4.2.0,
current version 4.3.0)
/sw/lib/ncurses/libncurses.5.dylib (compatibility version 5.0.0,
current version 5.0.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current
version 111.1.1)
/usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current
version 227.0.0)
/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current
version 1.0.0)

Thanks.


#4

Mark F. wrote:

Well I run the configure script with ‘–with-readline-dir=/usr/local’
and I get:

configure: WARNING: unrecognized options: --with-readline-dir

–and I get this with whatever I specify as the directory (which I think
is because there is no such option in the configure script).

I have tried with every 1.9.x distro.

I am getting this same error (and I have successfully compiled and
installed the new readline). It seems that the people that this works
for are running Leopard. Not sure why the configure script would not
recognize this option under Tiger.

Can anyone confirm whether the “–with-readline-dir” option works under
Tiger?


#5

Mark F. wrote:

Hello,

I am trying to build Ruby 1.9 on Mac OSX x86 Tiger.

What version did you have before 1.9? Did you install it yourself? I’m
using the pre-installed ruby 1.8.2 on mac osx tiger(intel), and awhile
ago I tried to upgrade to 1.8.6 using a “Ruby one click installer”
linked to on the ruby home page, but it broke my ruby tk–and it did not
come with an unistaller! So I had to write a ruby program, with the
help of someone on the forum, to delete all the files.

Currently, my version of ruby gems is disfunctional/broken, but the
latest upgrades don’t work with my version of ruby. So…I would like
to upgrade to ruby 1.8.6 and install the latest gem software to get rid
of all my ruby problems. Do you have any advice on how to do that?


#6

Hi,

I’m having the exact same problem. I tried stuff posted in this thread
but none worked.


#7

On Feb 12, 12:23 am, John S. removed_email_address@domain.invalid wrote:

I am getting this same error (and I have successfully compiled and
installed the new readline). It seems that the people that this works
for are running Leopard. Not sure why the configure script would not
recognize this option under Tiger.

Can anyone confirm whether the “–with-readline-dir” option works under
Tiger?

Try running autoconf before running configure.

-Stephen