How much Active connections on nginx for window?

i stress test nginx on window2003,but the action connections never in
excess of 512。
why?my config:

worker_processes 1;

events {
worker_connections 1024;
}

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,3233,3233#msg-3233

Active connections: 512
server accepts handled requests
6855 5279 5298
Reading: 1 Writing: 511 Waiting: 0

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,3233,3234#msg-3234

On Sun, Jun 21, 2009 at 11:56:52PM -0400, afen wrote:

i stress test nginx on window2003,but the action connections never in excess of 512???
why?my config:

worker_processes 1;

events {
worker_connections 1024;
}

Is anything in error_log ?

What’s the system TCP connection limitation? Please check registery
setting.

2009/6/22 afen [email protected]

On Mon, Jun 22, 2009 at 6:56 AM, afen[email protected] wrote:

host has failed to respond) while connecting to upstream, client: 192.168.1.100, server: localhost, request: “GET /index.php HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “localhost”

Probably because you use two connections when proxying - one for
client connection - one for backend.

On Mon, Jun 22, 2009 at 06:30:18PM +0300, zepolen wrote:

Posted at Nginx Forum: http://forum.nginx.org/read.php?2,3233,3233#msg-3233

host has failed to respond) while connecting to upstream, client: 192.168.1.100, server: localhost, request: “GET /index.php HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “localhost”

Probably because you use two connections when proxying - one for
client connection - one for backend.

Yes, you are right.

deltay Wrote:

What’s the system TCP connection limitation?
Please check registery setting.

I test the IIS,it’s more than 10000 connections

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,3233,3258#msg-3258

host has failed to respond) while connecting to upstream, client:
192.168.1.100, server: localhost, request: “GET /index.php HTTP/1.1”,
upstream: “fastcgi://127.0.0.1:9000”, host: “localhost”

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,3233,3257#msg-3257

2009/06/22 00:35:02 13036#13056: *6757 maximum number of descriptors
supported by select() is 1024 while connecting to upstream, client:
192.168.1.100, server: localhost, request: “GET /index.php HTTP/1.1”,
upstream: “fastcgi://127.0.0.1:9000”, host: “localhost”

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,3233,3259#msg-3259

Igor S. Wrote:

events {
upstream: “fastcgi://127.0.0.1:9000”, host:
“localhost”

Probably because you use two connections when
proxying - one for
client connection - one for backend.

Yes, you are right.

how can i do?this is my config

worker_processes 1;

events {
worker_connections 10240;
}

http {
include mime.types;
default_type application/octet-stream;

sendfile        on;
#tcp_nopush     on;

#keepalive_timeout  0;
keepalive_timeout  65;

#gzip  on;

server {
    listen       80;
    server_name  localhost;

    location / {
        root   /NPMserv/www;
        index  index.html index.htm index.php;
    }

    error_page   500 502 503 504  /50x.html;
    location = /50x.html {
        root   html;
    }

   location ~ .*\.php?$ {
        root           /NPMserv/www;
        fastcgi_pass   127.0.0.1:9000;
        fastcgi_index  index.php;
       fastcgi_param  SCRIPT_FILENAME 

/NPMserv/www$fastcgi_script_name;
include fastcgi_params;
}
}

}

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,3233,3286#msg-3286