How do I apply a patch to Rails?


#1

Hi,

How do I apply a patch to Rails?

From what I can find it looks like I need to be running on the latest
version from SVN.

I don’t want to do that however.

I have also tried applying the changes to the .rb file concerned, but
that didn’t seem to work.

Martin


#2

You may not have to. I have had some luck with overriding rails bits
by copying them into config/environment.rb and
app/helpers/application_helper.rb and tinkering them there.

I was able to implement text_field_with_index_auto_complete and the
associated auto_complete_with_index_for without patching anything so I
could use them for forms with multiple records.


#3

On Tuesday 11 April 2006 15:58, Martin Smith wrote:

I have also tried applying the changes to the .rb file concerned, but
that didn’t seem to work.

Martin

You can also run “rake rails:freeze:gems” to get a frozen copy of the
gem in
your vendor directory. Note that this was broken in 1.1 and fixed again
in
1.1.1. Also, in 1.0 the command is different but I forget what it was

Ashley