Hosting with speedyrails

hello everyone,

original app: rails 3.1.1
ruby 1.9.2p180 (2011-02-18 revision 30909)
[i686-linux]

I try to host my app into speedyrails using capistrano.
I host my sample application and running. I just get only one error like
my assets
were not precompiled. then i solve that by adding “load ‘deploy/assets’”
this code in my deploy receipt.
and my sample app worked well.

Now i am trying to host my original app, while i try deploy “cap
deploy” i
am getting following error…

  • executing `deploy:assets:precompile’
  • executing “cd /var/www/apps/app-name/releases/20120818100526 &&
    bundle
    exec rake RAILS_ENV=production RAILS_GROUPS=assets assets:precompile”
    servers: [“myserver”]
    [myserver] executing command
    *** [err :: myserver]
    /var/www/apps/app-name/shared/bundle/ruby/1.9.1/gems/therubyracer-0.9.4/lib/v8/portal.rb:50:
    *** [err :: myserver] [BUG]
    *** [err :: myserver] Segmentation fault
    *** [err :: myserver]
    *** [err :: myserver] ruby 1.9.2p180 (2011-02-18 revision 30909)
    [x86_64-linux]
    *** [err :: myserver]
    *** [err :: myserver] – control frame ----------
    *** [err :: myserver] c:0120
    *** [err :: myserver] p:----
    *** [err :: myserver] s:0469 b:0469
    *** [err :: myserver] l:000468
    *** [err :: myserver] d:000468
    *** [err :: myserver] CFUNC
    *** [err :: myserver] :New
    *** [err :: myserver]
    .
    .
    .
    .
    .
    .
    *** [err :: myserver]
    /var/www/apps/app-name/shared/bundle/ruby/1.9.1/gems/therubyracer-0.9.4/lib/v8/portal.rb:50:in
    v8' *** [err :: myserver] /var/www/apps/app-name/shared/bundle/ruby/1.9.1/gems/therubyracer-0.9.4/lib/v8/portal.rb:50:inNew’
    *** [err :: myserver]
    *** [err :: myserver] – C level backtrace information

*** [err :: myserver] ruby(rb_vm_bugreport+0xbd) [0x815ffcd]
*** [err :: myserver] ruby() [0x819ee0e]
*** [err :: myserver] ruby(rb_bug+0x28) [0x819eec8]
*** [err :: myserver] ruby() [0x80f2550]
*** [err :: myserver] [0xf77d9410]
*** [err :: myserver] [0xbd0fc70]
*** [err :: myserver]
*** [err :: myserver] [NOTE]
*** [err :: myserver] You may have encountered a bug in the Ruby
interpreter or extension libraries.
*** [err :: myserver] Bug reports are welcome.
*** [err :: myserver] For details:
http://www.ruby-lang.org/bugreport.html
*** [err :: myserver]
*** [err :: myserver] Aborted
command finished in 16336ms
*** [deploy:update_code] rolling back

  • executing “rm -rf /var/www/apps/app-name/releases/20120818100526;
    true”
    servers: [“myserver”]
    [myserver] executing command
    command finished in 665ms
    failed: “sh -c ‘cd /var/www/apps/app-name/releases/20120818100526 &&
    bundle
    exec rake RAILS_ENV=production RAILS_GROUPS=assets assets:precompile’”
    on
    myserver

Please advice!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs