Hosting with Pair : Rails' app dies after a few seconds


#1

First of all thanks a lot to the guys who answered the other topic.

Host: Pair Networks - FreeBSD v.4.8-Stable - peulik.pair.com
PHP and MySQL services running (is this a problem?)

First of all, after I establish the ssh connection I’ve to type, as I
mentioned in the old thread,
GEM_PATH ~/lib/ruby/gems/1.8
otherwise the ruby installation is not found.

position of the executable:
%which ruby
/usr/local/bin/ruby

May be this the problem? this should be the directory of the default
pair istallation.
Since I installed a new version which is placed in /home/“myaccount”/bin
I guess this could be the problem.
Is there a way to correct it?

anyway, if I type
%ruby -v
i get
ruby 1.8.3 (2005-09-21) [i386-freebsd4.8]

so I guess it is correct


%rails -v
Rails 1.0.0

Well, everything seems to work.

% cd public_html
(my site directory is placed in public_html/sito1)
%rails testapp
create
create app/controllers
create app/helpers
create app/models
create app/views/layouts
create config/environments
create components
create db
create doc
create lib
create lib/tasks
create log
create public/images
create public/javascripts
create public/stylesheets
create script/performance
create script/process
create test/fixtures
create test/functional
create test/mocks/development
create test/mocks/test
create test/unit
create vendor
create vendor/plugins
create Rakefile
create README
create app/controllers/application.rb
create app/helpers/application_helper.rb
create test/test_helper.rb
create config/database.yml
create config/routes.rb
create public/.htaccess
create config/boot.rb
create config/environment.rb
create config/environments/production.rb
create config/environments/development.rb
create config/environments/test.rb
create script/about
create script/breakpointer
create script/console
create script/destroy
create script/generate
create script/performance/benchmarker
create script/performance/profiler
create script/process/reaper
create script/process/spawner
create script/process/spinner
create script/runner
create script/server
create script/plugin
create public/dispatch.rb
create public/dispatch.cgi
create public/dispatch.fcgi
create public/404.html
create public/500.html
create public/index.html
create public/favicon.ico
create public/robots.txt
create public/images/rails.png
create public/javascripts/prototype.js
create public/javascripts/effects.js
create public/javascripts/dragdrop.js
create public/javascripts/controls.js
create doc/README_FOR_APP
create log/server.log
create log/production.log
create log/development.log
create log/test.log
%cd testapp
%ruby script/server
=> Booting WEBrick…
=> Rails application started on http://0.0.0.0:3000
=> Ctrl-C to shutdown server; call with --help for options

now I can reach the index page of the application for few seconds at
http://www.micheleongaro.com:3000

then

Killed
%

This is the end.
It may help if i report the verbose mode?

Thanks in advance!

Michele


#2

On 7/01/2006, at 10:44 PM, Cattimik wrote:

position of the executable:
%which ruby
/usr/local/bin/ruby

export PATH="$HOME/bin:$PATH"
will get your Ruby executable in the search path

Killed

This is a message from the kernel indicating that the process has
been killed with SIGKILL (kill -9). My guess is your host is running
a process that kills all processes of a certain type every few seconds.

Personally I’m with them on this if they’re a shared host - Rails in
development mode eats RAM really fast, and on a shared host this
rapidly creates performance issues. Develop on your own machine,
deploy to them.


Phillip H.
removed_email_address@domain.invalid


#3

Phillip H. wrote:

This is a message from the kernel indicating that the process has
been killed with SIGKILL (kill -9). My guess is your host is running
a process that kills all processes of a certain type every few seconds.

Personally I’m with them on this if they’re a shared host - Rails in
development mode eats RAM really fast, and on a shared host this
rapidly creates performance issues. Develop on your own machine,
deploy to them.


Phillip H.
removed_email_address@domain.invalid

I see and agree with you.
I just didn’t know this.
I’ll do what you suggested.

Thanks a lot,

Michele