Help with SCGI please :(


#1

Hi,

While learning Ruby and Rails, I decided I just as well learn Linux
along the way… It’s been fun, but I’m stuck at one of those
exasperating moments… I hope someone can help me :slight_smile:

I installed Ruby 1.8.4 on Fedora Core 4, then Rails, then lighty, and
then SCGI.

I used yum to install lighty… and it already comes with mod_scgi.

I created my first application in /home/tango/ and I configured lighty
using the instructions here:

http://www.zedshaw.com/projects/scgi_rails/lighttpd.html

However, when I try to start lighty, I get the following error:

(mod_scgi.c.1050) missing key (short): scgi.server dispatch.scgi 0 port
2006-02-22 17:06:50: (server.c.834) Configuration of plugins failed.
Going down.

On lighttpd.conf I have the following relevant lines:

server.document-root = “/home/tango/public/”
server.error-handler-404 = “/dispatch.scgi”
scgi.server = ( “dispatch.scgi” => (( “host” => “127.0.0.1”, “port” =>
9999, “check-local” => “disable” )) )

What of all things could I possibly be doing wrong?

Kind regards,
Ivan V.


#2

Did you use:

scgi_ctrl config

and

scgi_ctrl start

as described in the Setup SCGI in Rails section of this page:
http://www.zedshaw.com/projects/scgi_rails/howto.html

Iván Vega R. wrote:

Hi,

While learning Ruby and Rails, I decided I just as well learn Linux
along the way… It’s been fun, but I’m stuck at one of those
exasperating moments… I hope someone can help me :slight_smile:

I installed Ruby 1.8.4 on Fedora Core 4, then Rails, then lighty, and
then SCGI.

I used yum to install lighty… and it already comes with mod_scgi.

I created my first application in /home/tango/ and I configured lighty
using the instructions here:

http://www.zedshaw.com/projects/scgi_rails/lighttpd.html

However, when I try to start lighty, I get the following error:

(mod_scgi.c.1050) missing key (short): scgi.server dispatch.scgi 0 port
2006-02-22 17:06:50: (server.c.834) Configuration of plugins failed.
Going down.

On lighttpd.conf I have the following relevant lines:

server.document-root = “/home/tango/public/”
server.error-handler-404 = “/dispatch.scgi”
scgi.server = ( “dispatch.scgi” => (( “host” => “127.0.0.1”, “port” =>
9999, “check-local” => “disable” )) )

What of all things could I possibly be doing wrong?

Kind regards,
Ivan V.


#3

Hi Ivan

I haven’t used lighty with scgi, but I am running it on core 4, and I
couldn’t get it to run rails and fcgi using the version available
from default core 4 repository… it was 1.2.something, which is
several months old I think. So I resinstalled from the tarball on the
lighty web site, and everything worked just fine. I don’t know what
version you’re running, but ifit’s real old maybe an upgrade will help?

Take care,
Sean


#4

Yep, that’s what I did.

Brad D. escribió:


#5

That looks to be about right, but maybe the SCGI syntax has changed for
lighttpd. Take a look at these instructions from turbogears:

http://www.cleverdevil.org/computing/34/deploying-turbogears-with-lighttpd-a
nd-scgi

And see how he’s got the $HTTP[“url”] syntax? Try something like that
just
to see if you can get it to at least talk to the scgi. If you can then
look
at the scgi.server = block and see if some of those changes fix it.

I may have to update the instructions soon if they have changed.

Zed A. Shaw


#6

Hah! That works!

Thanks a lot!

Ivan V.

Zed S.
escribió:> That looks to be about right, but maybe the SCGI syntax has changed for