Help with installing thrift with ruby 1.9.3

Hello,

I have the system environment as:

ruby -v

ruby 1.9.3p392 (2013-02-22) [x86_64-linux]

gem -v

2.0.3

cat /etc/issue

Ubuntu 10.04.4 LTS \n \l

I can’t get success to install Thrift (thrift-0.9.0) on the host, when
“make install” I always got:


Finished in 3.31 seconds
364 examples, 0 failures, 1 pending
gem build thrift.gemspec
WARNING: prerelease dependency on mongrel (= 1.2.0.pre2, development)
is not recommended
Successfully built RubyGem
Name: thrift
Version: 0.9.0.1
File: thrift-0.9.0.1.gem
gem install thrift-.gem
ERROR: Could not find a valid gem 'thrift-
.gem’ (>= 0) in any
repository
rake aborted!
Command failed with status (2): [gem install thrift-*.gem…]

Tasks: TOP => install
(See full trace by running task with --trace)
make[4]: *** [install-exec-hook] Error 1
make[4]: Leaving directory /root/thrift-0.9.0/lib/rb' make[3]: *** [install-exec-am] Error 2 make[3]: Leaving directory/root/thrift-0.9.0/lib/rb’
make[2]: *** [install-am] Error 2
make[2]: Leaving directory /root/thrift-0.9.0/lib/rb' make[1]: *** [install-recursive] Error 1 make[1]: Leaving directory/root/thrift-0.9.0/lib’
make: *** [install-recursive] Error 1
[email protected]:~/thrift-0.9.0# gem install thrift -v 0.9.0.1
ERROR: Could not find a valid gem ‘thrift’ (= 0.9.0.1) in any
repository
ERROR: Possible alternatives: thrift
[email protected]:~/thrift-0.9.0# ruby -v
ruby 1.9.3p392 (2013-02-22) [x86_64-linux]

Please help, thanks!

IIRC, Debian has different packaging philosophies, and disables Rubygems
so
that you will use their package manager to install specific versions of
gems that they’ve vetted (the Ruby community moves very fast, but the
Debian team is concerned with stability).

I believe to get around this, most people build their own Ruby or use a
version manager
https://www.ruby-toolbox.com/categories/ruby_version_management

-Josh