Help with Installation on OpenSolaris (TextDrive Containers)

Gents,

I installed ferret successfully in my MacOS (rails development) using
the gem install. I did some tests and everything worked fine.

Then I tried to install it on the same way on my production environment
at TextDrive? running OpenSolaris? (container). This time ‘gem install
ferret’ seems to be completed:

[92140-AA:~/web/labs/blogblogs/trunk] root# gem install ferret
Attempting local installation of ‘ferret’ Local gem file not found:
ferret*.gem Attempting remote installation of ‘ferret’ Select which gem
to install for your platform (i386-solaris2.8)

  1. ferret 0.10.14 (ruby)
  2. ferret 0.10.13 (ruby) …
  3. ferret 0.1.0 (ruby)
  4. Cancel installation
1

Building native extensions. This could take a while… make: cc: Command
not found make: *** [helper.o] Error 127 make: cc: Command not found
make: *** [helper.o] Error 127 ruby extconf.rb install ferret creating
Makefile

make cc -KPIC -xO3 -xarch=386 -xspace -xildoff -I/opt/csw/include
-I/opt/csw/include -KPIC -fno-common -D_FILE_OFFSET_BITS=64 -I.
-I/opt/csw/lib/ruby/1.8/i386-solaris2.8
-I/opt/csw/lib/ruby/1.8/i386-solaris2.8 -I. -I/opt/csw/include
-I/opt/csw/include -c helper.c

make install cc -KPIC -xO3 -xarch=386 -xspace -xildoff
-I/opt/csw/include -I/opt/csw/include -KPIC -fno-common
-D_FILE_OFFSET_BITS=64 -I. -I/opt/csw/lib/ruby/1.8/i386-solaris2.8
-I/opt/csw/lib/ruby/1.8/i386-solaris2.8 -I. -I/opt/csw/include
-I/opt/csw/include -c helper.c Successfully installed ferret-0.10.14
Installing RDoc documentation for ferret-0.10.14…

Then I tried to run and I’m always getting a require no such file to
load error, see:

[92140-AA:~/web/labs/blogblogs/trunk] pocscom$ irb irb(main):001:0>
require ‘ferret’ LoadError?: no such file to load – ferret

from (irb):1:in `require' from (irb):1

irb(main):002:0> require ‘rferret’ LoadError?: no such file to load –
rferret

from (irb):2:in `require' from (irb):2

irb(main):003:0>

Any suggestions?

On 1/21/07, Manoel L. [email protected] wrote:

from (irb):2:in `require' from (irb):2

irb(main):003:0>

Any suggestions?

try:

require “rubygems”
require_gem “ferret”
require “ferret”


Linux Just Simply Rocks!
[email protected] | [email protected]
http://deathwing.penarmac.com/
GPG: 0xD6655C18

Gents,

Just found the error and the solution.

Error: CC no present on my OpenSolaris installation.

make: cc: Command not found
make: *** [helper.o] Error 127
make: cc: Command not found
make: *** [helper.o] Error 127

Solution: Use the new rbconfig file provided by TextDrive

Details here: http://forum.textdrive.com/viewtopic.php?id=12630

I just renamed my old rbconfig.rb to rbconfig.rb.original and
downloaded this one http://www.cuddletech.com/rbconfig.rb

Things are now working fine.

Special thanks to Jason from TextDrive for the hint.

[]s

Manoel

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs