Help with Apache on Suse 10


#1

Ciao,
sorry if I will say some things that will not make any sense, but I have
a limited experience with Ruby, Apache and Linux in general, and
therefore ask you all for help.

I’ve configured Apache 2.3 to run on Suse Server Enterprise 10, and it
works fine (can easily get index page).
Then installed Ruby on Rails, and if I start the Test application with
the included web server (sorry cannot remember the name at the moment as
I not at work), on port 3000 it works fine (also configured MySQL).

Then tried to configure Ruby to run with Apache, but cannot get it to
run. If I setup a Virtual Host, it tells me it does not have
permissions setup…
After many tentatives, noticed that somehow Apache was not accepting the
Ruby Module (or at list the module shows as not accepted in Apache
Console (YAST)), therefore installed FastCGI, activated, and retried but
result still the same.
Can anyone help me with this or adress me to some clear site about this
issue?
Thank you in advance.
Ciao

Strider