Help wanted: pg vs. postgres-pr gems

Hi all,

I installed Rails 3.0 + PostgreSQL 8.4.
Installed the gem postgre-pr
I added " gem ‘postgres-pr’ " to my Gemfile
I defined my database.yml with:

PostgreSQL 8.4

development:
adapter: postgresql
encoding: unicode
database: testdb
pool: 5
username: test
password: ******

I run rails server which starts, but application environment returns
this error:
no such file to load – pg

Any idea about where this comes from ?

Thanks for help !

Fred

On 11-10-26 11:38 AM, Frdric C. wrote:

database: testdb
Thanks for help !

Fred

You will need to locate where pg_config is installed, if you are on
linux then you can type:

$ which pg_config
/usr/local/pgsql/bin/pg_config

Plug that into gem install command like this:

sudo gem install pg – --with-pg-config=/usr/local/pgsql/bin/pg_config

Also in your database.yml, you should also add (for local development)

host: localhost


Kind Regards,
Rajinder Y. | http://DevMentor.org | Do Good! ~ Share Freely

2011/10/26 Frdric C. [email protected]:

no such file to load – pg

gem install pg

On Thu, Oct 27, 2011 at 7:43 AM, Rajinder Y. [email protected]
wrote:

adapter: postgresql
Any idea about where this comes from ?
/usr/local/pgsql/bin/pg_config

Plug that into gem install command like this:

sudo gem install pg – --with-pg-config=/usr/local/**pgsql/bin/pg_config

Also in your database.yml, you should also add (for local development)

host: localhost

At least on UNIX, for local development, a host: is not always required.

One can also connect over a local Unix-domain socket, possibly without
a password (because already authenticated to the Operating System).
The detailed setting of access rights for these 2 cases is covered in
the
file /etc/postgresql/8.4/main/pg_hba.conf.

HTH,

Peter

Rajinder Y. wrote in post #1028746:

On 11-10-26 11:38 AM, Frdric C. wrote:

database: testdb
Thanks for help !

Fred

You will need to locate where pg_config is installed, if you are on
linux then you can type:

$ which pg_config
/usr/local/pgsql/bin/pg_config

Plug that into gem install command like this:

sudo gem install pg – --with-pg-config=/usr/local/pgsql/bin/pg_config

Also in your database.yml, you should also add (for local development)

host: localhost


Kind Regards,
Rajinder Y. | http://DevMentor.org | Do Good! ~ Share Freely

Well, thanks for your help !
Indeed, I had to install libpq-dev, locate pg_config, and then the pg
gem.
It’s my first try with PostgreSQL, and I not sure to understand why the
postgre-pr gem was not sufficient ?
But it works fine now !
Thanks for your help !
Best regards,
Fred

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs