Help! RubyGems is broken!


#1

I have a problem with RubyGems:

ruby gt.rb
ruby: no such file to load – ubygems (LoadError)

Here are my compiler and gem versions:

ruby --version
ruby 1.8.7p5000 (2009-03-03 revision 22728) [x86_64-linux] <>

gem --version
1.3.1 <>

When I built rubygems, I saw a reference to ‘ubygems’, but it looked
like a typo.

The source program has a "require ‘rubygems’ " line, and my profile
file has a “RUBYOPT=rubygems” environment variable set.

I am at a loss to determine what is causing this.


#2

Could you not try re-installing ruby gems??

Cheers

Richard


#3

remove the rubyopt thing from your profile. I have seen that cause
this exact error on many systems.
Of course, restart your terminal session after changing your profile. :slight_smile: