Help restarting smpl.se, application failure, Radiant, Site5

Below is a ticket i filed with Site5 a few minutes ago, but I think
maybe the Radiant pros will be better at helping me out.

My site http://smpl.se/ has broken, giving me the error:

Application error (Apache)

Change this error message for exceptions thrown outside of an action
(like in Dispatcher setups or broken Ruby code) in public/500.html

The admin tools for Radiant still work, however. This leads me to
belive that I typed something in a snoppet or layout or page that
broke something.

Only trouble I don’t even know where to begin looking. I don’t know
where the log files are, and if I found them I wouldn’t know what
they mean.

I want to restart Rails or Apache or fcgi or whatever, but I don’t
know what I run or how to do this in my particular instance (Site5,
some old version of Rails etc.).

I run Radiant 0.6 i think.

I’d be happy to exchange services and help out if somebody can help
me get http://smpl.se/ up, and get everything configured correctly,
running good versions of everything.

Below is my support ticket to Site5.

Regards,

Martin O.

[email protected]

=== Ticket Body ===

I’m a rookie at configuring stuff like this and I’m not a Linux power
user. I may also have messed something up by doing something stupid
in Radiant CMS.

I have managed to get my site up and running with Ruby on Rails and
Radiant CMS by reading guides and following few threads in your
excellent forums.

I have been happy though response times have sometimes been long
(don’t know if this is an app or network issue). I’m in creative mode
so I’ve been tweaking things on the site using only the admin-console
for Radiant and publishing loads of stuff.

Now something is broken, and I don’t know how to restart the server.

I think my whole configuration is in need of an upgrade. I need to
upgrade to a later version of Radiant and Rails - maybe start using
Capistrano or Switchtower or whatever it’s called.

I would also like to set up a Subversion repository and implement
some kind of automatic deploy functionality (is this Capistrano)?

Apart from helping me get http://smpl.se/ up again, I realise this is
not not support, but if you could give some pointers or recommend
somebody I’d be very happy.

I’m prepared to pay, but have a very limited budget.

Regards,
Martin O.


[email protected]

Fast response, i’m in a hurry:

If the admin UI is working, start marking pages as “not published”
until
you find the page that is causing the problem. From there, try to
isolate
the snippet.

Anyway, think in your last modifications to the site to help find the
problem.

All this assuming that the problem is your side, and not in the
server
(gem updates, DB updates…)

/AITOR

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs