Help -- qt, ruby, ms-windows?

Hi there…

Is there someone who is successfully running qtruby with mswin32 and
ruby 1.8.7 for qt v6.3?

If that’s you – What did you need to install and do to get it
working?

Also for the qt people, I love the tutorials and examples – BUT none
of them say how to install a working set-up. If they do it is well
hidden.

All in all it seems that how the qt support is being done for ruby is
far to complex. With ruby in particular the normal thing is just to
load a gem and things work.

Any ideas?

Thanks,
Will

Hi,

On 27.09.2010 02:59, will wrote:

Is there someone who is successfully running qtruby with mswin32 and
ruby 1.8.7 for qt v6.3?

Not exactly, I’m found this following versions to work for me on Windows
7 64bit:

ruby 1.9.1p430 ( rubyinstaller-1.9.1-p430 )

And then from command line I installed “gem install qtbindings”.

qtbindings is afaik a recent approach because qtruby4 doesn’t work out
of the box for non-windows plattforms, at least it didn’t for me.

Also for the qt people, I love the tutorials and examples – BUT none
of them say how to install a working set-up. If they do it is well
hidden.

All in all it seems that how the qt support is being done for ruby is
far to complex. With ruby in particular the normal thing is just to
load a gem and things work.

I’m with you here, until I disocvered qtbindings. It still a bit rough
and being worked on, though. I’ve set up a recent environment for python
and Qt and it worked much more flawless.

HTH,

  • Markus

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs