Help needed with spdy

Hi,

I’m usually compiling nginx from source (currently using 1.3.3). As
I’ve read that spdy success story yesterday I thought I’d try that
myself. So I got 1.3.3 again patched it using spdy.patch-47.txt,
downloaded OpenSSL 1.0.1c and configured nginx using
‘–with-http_ssl_module
–with-openssl=/usr/src/nginx/source/openssl-1.0.1c
–with-sha1=/usr/src/nginx/source/openssl-1.0.1c
–with-md5=/usr/src/nginx/source/openssl-1.0.1c’ besides my other
defaults (full nginx -V & uname -a as well as my config which I’m
running for that host here:
https://gist.github.com/5f7ff6c8e347371042e7).

The site which I’m running (with ‘ssl’ and ‘spdy’ within the listen
directive) on this host currently is a redmine installation where
nginx delivers all static assets and passes anything else to thin.
Another vHost (running phpmyadmin there) on that server is spdy
enabled too - but listening on both. HTTP and HTTPS. Any access for
testing there is running through https anyway.

However neither Chrome (v22 with spdy enabled) nor Firefox (v14, spdy
enabled too) indicate that spdy is used on any of those hosts. Any
ideas what’s going be wrong here?

Regards,
Chris

On Wednesday 25 July 2012 16:18:01 Christian B. wrote:

defaults (full nginx -V & uname -a as well as my config which I’m
However neither Chrome (v22 with spdy enabled) nor Firefox (v14, spdy
enabled too) indicate that spdy is used on any of those hosts. Any
ideas what’s going be wrong here?

Could you provide a debug log?
http://nginx.org/en/docs/debugging_log.html

wbr, Valentin V. Bartenev

Yes, here you are: https://gist.github.com/db1281399f571ec1de2b. That
was created using the debug_connection directive on another - less
production critical - Host I can “play” with. 100% the same setup
(like os, compiler, openssl, nginx, configure-options & stuff). nginx
Config is the same (exept some paths where the application itself
lives). This host is showing the same problem.

Regards,
Christian

2012/7/25 Valentin V. Bartenev [email protected]:

On Wednesday 25 July 2012 17:22:00 Christian B. wrote:

Yes, here you are: https://gist.github.com/db1281399f571ec1de2b. That
was created using the debug_connection directive on another - less
production critical - Host I can “play” with. 100% the same setup
(like os, compiler, openssl, nginx, configure-options & stuff). nginx
Config is the same (exept some paths where the application itself
lives). This host is showing the same problem.

Thanks! Could you try the new patch?

http://nginx.org/patches/spdy/patch.spdy-48.txt

wbr, Valentin V. Bartenev

On Thursday 26 July 2012 00:03:38 Christian Boenning wrote:

That’s working now across both browsers for both Virtual Hosts on that
Server. I’ll push that patch to my production Servers soon and will
monitor closely how it performs.

Thank you, Valentin!

Thank you for the report. This was a little bug with the “spdy”
parameter
of the “listen” directive. It might not work in some certain virtual
host
configurations.

wbr, Valentin V. Bartenev

That’s working now across both browsers for both Virtual Hosts on that
Server. I’ll push that patch to my production Servers soon and will
monitor closely how it performs.

Thank you, Valentin!

Best,
Chris

Am 25.07.2012 um 19:20 schrieb Valentin V. Bartenev: