Help me out!


#1

am posting the error i get from Ruby here…am i missing a particular
gem ?

START
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.1.0 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…
Exiting
d:/instantrails-2.0-win/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.0/lib/acti
ve_support/core_ext/module/aliasing.rb:31:in alias_method': undefined methodf
ind_full_template_path’ for class ActionView::Base' (NameError) from d:/instantrails-2.0-win/ruby/lib/ruby/gems/1.8/gems/activesupport-2 .1.0/lib/active_support/core_ext/module/aliasing.rb:31:inalias_method_chain’
from
D:/InstantRails-2.0-win/demo/bedrock_testing/bedrock/trunk/vendor/p
lugins/active_scaffold/lib/extensions/generic_view_paths.rb:33
from
d:/instantrails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems/custom
_require.rb:27:in gem_original_require' from d:/instantrails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems/custom _require.rb:27:inrequire’
from
d:/instantrails-2.0-win/ruby/lib/ruby/gems/1.8/gems/activesupport-2
.1.0/lib/active_support/dependencies.rb:509:in require' from d:/instantrails-2.0-win/ruby/lib/ruby/gems/1.8/gems/activesupport-2 .1.0/lib/active_support/dependencies.rb:354:innew_constants_in’
from
d:/instantrails-2.0-win/ruby/lib/ruby/gems/1.8/gems/activesupport-2
.1.0/lib/active_support/dependencies.rb:509:in require' from D:/InstantRails-2.0-win/demo/bedrock_testing/bedrock/trunk/vendor/p lugins/active_scaffold/environment.rb:63 ... 46 levels... from d:/instantrails-2.0-win/ruby/lib/ruby/gems/1.8/gems/rails-2.1.0/lib /commands/server.rb:39 from d:/instantrails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems/custom _require.rb:27:ingem_original_require’
from
d:/instantrails-2.0-win/ruby/lib/ruby/site_ruby/1.8/rubygems/custom
_require.rb:27:in `require’
from script/server:3

what to do???


#2

Hi Sushrut,

It seems like ActionView::Base does not have the
#find_full_template_path method. Which is right,
regarding to that website:
http://apidock.com/rails/v2.0.3/ActionView/Base/find_full_template_path

I never used instanrails or even rails on windows. What I can say is
that either you updated the rails gem,
either the demo they ship was not updated. To solve it out, try
installing rails 2.0.3 and force it’s version in the railsapp
environment.

Cheers,
zimbatm