Help! installing rubygems in ubuntu... problems with zlib


#1

Hi,

I am trying to install Ruby on Rails on a Linux Ubuntu PC. I already
installed manually ruby 1.8.4. But when I try to install rubygems, I get
the error:

/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__': no such file to load -- zlib (LoadError) from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:9
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/builder.rb:1 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:61:in
manage_gems' from /home/carlos/Desktop/rubygems-0.8.11/./post-install.rb:64:ininstall_sources’
from
/home/carlos/Desktop/rubygems-0.8.11/./post-install.rb:75:in
try_run_hook' from setup.rb:577:inrun_hook’
from setup.rb:1315:in exec_task_traverse' from setup.rb:1168:inexec_install’
from setup.rb:887:in exec_install' from setup.rb:705:ininvoke’
from setup.rb:674:in `invoke’
from setup.rb:1352

I installed zlib with the package manager (libzlib-ruby) and manually,
even recompiled ruby, but still I get this error… I searched for info
on this problem, but all I found was that the problem should be solved
with libzlib-ruby…

Help!

Thanks a lot,
Carlos


#2

Carlos Gershenson wrote:

I installed zlib with the package manager (libzlib-ruby) and manually,
even recompiled ruby, but still I get this error… I searched for info
on this problem, but all I found was that the problem should be solved
with libzlib-ruby…

Help!

Thanks a lot,
Carlos

Here’s a very terse howto I wrote not to long ago detailing a build from
source

http://mgreenly.metaspot.net/?p=37


#3

Great! Thanks a lot! That did the works…
I guess the main step was to install ruby-zlib, that is not mentioned on
the places I checked…

Michael G. wrote:

Here’s a very terse howto I wrote not to long ago detailing a build from
source

http://mgreenly.metaspot.net/?p=37


#4

Michael G. wrote:

Carlos Gershenson wrote:

I installed zlib with the package manager (libzlib-ruby) and manually,
even recompiled ruby, but still I get this error… I searched for info
on this problem, but all I found was that the problem should be solved
with libzlib-ruby…

Help!

Thanks a lot,
Carlos

Here’s a very terse howto I wrote not to long ago detailing a build from
source

http://mgreenly.metaspot.net/?p=37

Too bad. Link is dead.
Sounded promising.