Help installing Rails app on server


I’ve been creating Rails apps on Mac OS X just fine, and I just got a
hosting account with, which offers Rails.

I uploaded an empty app, just to see if I can get the “Welcome Aboard”
page. I did get that page, but when I click on “About your
application’s environment”, I get “Not Found - Sorry, the requested URL
/testapp/public/rails/info/properties was not found on this server.”

I’ve requested support from the host, and they say they cannot help me,
that other users have gotten it to work, and that it is a coding issue.

I’ve also tried uploading a working app, setting up the database, etc,
and am not able to access the app at all. I figured I should get the
first “Welcome About” page problem fixed first.


Ok so that’s weird. (That’s my name too!). The only thing that I can
of about your predicament is that perhaps you did not upload the whole
shebang, or you are having some permissions issues.


Wow, that is very strange. You even spell it right. You’re not part of
the Johnston/Lansdale family are you? (There are a lot of Philips in my

About the Rails problem, my app is called “testapp”, and I just uploaded
the entire testapp directory into the httpdocs folder. I didn’t do
anything with the permissions, as I wouldn’t know what to do, and I
haven’t read that you need to…


Hmm, I’m not very familiar with hosting services, since I run my apps
out of
my garage on a box that I control. Are you possibly going from a Mac to
Unix? I had some issues with that cause OSX does is not case sensitive,
I have not had any troubles with what your trying to do. It might be
the hosting provider needs to have your Lighttpd configuration adjusted
their service.

As for families, we are out of Oklahoma, additionally I think we are a
going back to who knows, but what I do know is that a distant relative
the first law man of the Oklahoma territory way back when, so we have
of Cherokee blood as well.