HELP Installing older versions of rails on OSX?

I am attempting to recreate an old install of a machine that failed
recently. I originally setup the machine using the guide found on
Hivelogic (Dan Benjamin).
Which would have reinstated all of my old environments (Ruby 1.8.6,
Rubygems 0.9.2 Rails 2.1.6)…

I can get Ruby installed fine, although I had to use 1.8.7 because of
RubyGems, which is running version 1.3.6) but when I try to

sudo gem install rails it won’t install because of

active support requires Ruby version >= 1.9.3

Can anyone help me in getting Rails setup with Ruby 1.8.7 and RubyGems
1.3.6 is there a way to pass the version of Rails to the gem installer ?

Thank you in advance.

Jeff

On Jul 15, 2014, at 12:19 PM, Jeff L. [email protected] wrote:

Can anyone help me in getting Rails setup with Ruby 1.8.7 and RubyGems
1.3.6 is there a way to pass the version of Rails to the gem installer ?

gem install rails -v 1.3.6

On Tue, Jul 15, 2014 at 11:19 AM, Jeff L. [email protected]
wrote:

I am attempting to recreate an old install of a machine that failed
recently.

This is exactly where you should be using rvm (http://rvm.io/).
You will save yourself a ton of pointless grief. Seriously.


Hassan S. ------------------------ [email protected]

twitter: @hassan

So with this, could I confidently install Rails 1.1.6 and Ruby 1.8.6 ?
Because thus far, attempting to get these two in line is turning out to
be a real headache… :frowning:

On Tue, Jul 15, 2014 at 2:17 PM, Jeff L. [email protected]
wrote:

So with this, could I confidently install Rails 1.1.6 and Ruby 1.8.6 ?

Yes. I just did a test install of those on an MBA running Mavericks.

rvm install ruby-1.8.6
rvm use ruby-1.8.6
gem install rake -v ‘0.8.7’ # just a random old version
gem install rails -v ‘1.1.6’

tickety-boo and bob’s y’r uncle :slight_smile:

You might have to do some sleuthing to figure out which versions
of other gems you need, but that’s a start.

Good luck.

Hassan S. ------------------------ [email protected]

twitter: @hassan