Having trouble running rails 2.0.2 on Leopard

Hi, I’ve just started getting into rails and up until today (for some
reason) I’ve been using Rails 1.2.6

So I updated to Rails 2.0.2 by using gem update, but now I’m not able to
run anything at all.

Let’s say I create a new app by doing:
“rails someApp”
Then when I try to start the server, this is what I get:

thomas$ script/server
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…
Exiting
/Users/thomas/Documents/Web/ruby/displaypictures/config/environment.rb:44:
undefined method time_zone=' for #<Rails::Configuration:0x1236698> (NoMethodError) from /Library/Ruby/Gems/1.8/gems/rails-2.0.2/lib/initializer.rb:47:inrun’
from
/Users/thomas/Documents/Web/ruby/displaypictures/config/environment.rb:13
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:27:inrequire’
from
/Library/Ruby/Gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:496:in
require' from /Library/Ruby/Gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:342:innew_constants_in’
from
/Library/Ruby/Gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:496:in
require' from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/rails.rb:155:inrails’
… 20 levels…
from /Library/Ruby/Gems/1.8/gems/rails-2.0.2/lib/commands/server.rb:39
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:27:inrequire’
from script/server:3

I’ve searched around and I still haven’t found a working solution.
Any help would be highly appreciated.

On 15 Apr 2008, at 12:01, Thomas Pedersen wrote:

Hi, I’ve just started getting into rails and up until today (for some
reason) I’ve been using Rails 1.2.6

So I updated to Rails 2.0.2 by using gem update, but now I’m not
able to
run anything at all.

short version: it sounds like it’s installed gems from
gems.rubyonrails.org which include edge gems that you probably don’t
want unless you know what you’re doing
Long version:
http://groups.google.com/group/rubyonrails-talk/browse_thread/thread/816758f158368da1/6c949c9a5afd4e4e?lnk=st&q=config+time_zone+gem#6c949c9a5afd4e4e

Fred

Thank’s for the reply.
I’m actually installing from gems.rubyforge.org

I also tried reinstalling rails all over, but without any result.

However, when I uninstalled Rails 2.0.2.9216 and was left with Rails
2.0.2 it works fine.
So I guess I’m good now.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs