Having difficulty with compiling in Ubuntu 8.04


#1

Hi All,

I’m having difficulty compiling in Ubuntu 8.04 because some stuff from
QT isn’t found, for example, qmemarray.h, which I can find in
/usr/include/qt3/qmemarray.h, however, I thought it should be using QT4
instead of QT3, and I have installed qwt 5.0.2-2 from the Ubuntu
repository. As of January 2008, the wiki says you must compile from
source, but it looks like it is in the repository now. The interesting
thing, is I have another machine running 8.10 instead of 8.04, and the
header file is only in the same qt3 location there, but it builds just
fine. Here is the code calling for that header:

/*!
\def QwtArray
Aliases QArray (Qt-2.x) and QMemArray (Qt-3.x) to QwtArray
*/
#ifdef QWT_NO_MEMARRAY
#include <qarray.h>
#define QwtArray QArray
#else
#include <qmemarray.h>
#define QwtArray QMemArray
#endif

Perhaps QWT_NO_MEMARRAY is set in 8.10 and not in 8.04.

Any tips would be appreciated.

Thanks,

Rob


#2

Hi Everyone,

After removing qt3-mt-dev, gnuradio builds just fine on Ubuntu 8.04. I
don’t think this is the real solution, but a work around because I at
least still have some qt3 legacy code I haven’t rewritten in QT4.

73,

Rob, KL7NA


#3

Agreed, Tom and I don’t have Qt3 on our systems as we have moved on.
I think we need to change the tests to look SPECIFICALLY for qt4 since
that is what we support.

Bob


#4

Thanks Bob!

That would be appreciated, especially here.

73,

Rob